Webseite der LBB kann nicht geöffnet werden

In diesem Forum gab es Support zum Scripting-Plugin von Karsten Strunk
qay
Beiträge: 25
Registriert: Di 18. Nov 2014, 18:05

Webseite der LBB kann nicht geöffnet werden

Beitrag von qay » Sa 2. Dez 2017, 22:19

Code: Alles auswählen

[02.12.2017 21:58:18] Synchronisierung via Scripting läuft
[02.12.2017 21:58:18]  
[02.12.2017 21:58:18] Synchronisiere Konto: 233-2.  -  ... - /, IBAN DE8310..197900 [Landesbank Berlin - Berliner Sparkasse]
[02.12.2017 21:58:18] Skript: hibiscus.script.lbbcreditcard.js, Version: 0.22.1
[02.12.2017 21:58:18] Java-Version: 1.8.0_151
[02.12.2017 21:58:18] Synchronisiere Kreditkarte '233-2.  -  ...- /, IBAN DE8310..197900 [Landesbank Berlin - Berliner Sparkasse]'
[02.12.2017 21:58:18] Kein PIN vorhanden. Frage Benutzer nach PIN
[02.12.2017 21:58:34] Speichere eingegebene PIN für aktuelle Sitzung
[02.12.2017 21:58:34] Speichere eingegebene PIN permanent
[02.12.2017 21:58:35] Öffne Login-Seite der LBB...
[02.12.2017 21:58:35] Webseite der LBB kann nicht geöffnet werden.
[02.12.2017 21:58:35] Exception: TypeError: originalPage.getPageEncoding is not a function
[02.12.2017 21:58:35] TypeError: originalPage.getPageEncoding is not a function
	at fixErrorsOnHtmlPage (<eval>:1018)
	at lbb_login (<eval>:296)
	at lbb_sync (<eval>:175)
	at lbb_sync_account_statement (<eval>:133)
[02.12.2017 21:58:35] Synchronisierung der Kreditkarte '233-2.  -  ... - /, IBAN DE8310..197900 [Landesbank Berlin - Berliner Sparkasse]' fehlgeschlagen.
[02.12.2017 21:58:35] Synchronisierung via Scripting erfolgreich beendet
Im Web ist Seite erreichbar und aufrufbar.
Hat Sparkasse was geändert oder habe ich etwas übersehen?

qay
Beiträge: 25
Registriert: Di 18. Nov 2014, 18:05

Re: Webseite der LBB kann nicht geöffnet werden

Beitrag von qay » Mi 13. Dez 2017, 22:15

Ergänzung:
Wenn ich von Webabfrage Konto nach Kreditkartenbanking will, funktioniert auch nicht.
Direkt klappt.

Ich benutze überall Nightly

little.yoda
Entwickler
Entwickler
Beiträge: 82
Registriert: Mi 18. Jun 2014, 23:00

Re: Webseite der LBB kann nicht geöffnet werden

Beitrag von little.yoda » Sa 16. Dez 2017, 17:33

Du hast anscheinend bereits HTMLUNIT aktualisiert, aber das Plugin ist noch nicht aktualisiert.

Fijama
Beiträge: 5
Registriert: So 17. Jan 2016, 17:40

Re: Webseite der LBB kann nicht geöffnet werden

Beitrag von Fijama » Sa 16. Dez 2017, 17:52

Habe den selben Fehler auch seit 25.11. Habe schon auf Jameica 2.6.6 und Hibiscus 2.6.0 gepatched, HTMLUNIT ist auf 2.28.0-Testing (mit dem 2.27 kam der selbe Fehler), das lbb-script auf 0.22.1?
Hat jemand eine Idee woran es liegt?

Code: Alles auswählen

16.12.2017 17:52:06] Synchronisiere Konto: LBB - Kreditkarte, IBAN DE8310..197900 [Landesbank Berlin - Berliner Sparkasse]
[16.12.2017 17:52:06] Skript: hibiscus.script.lbbcreditcard.js, Version: 0.22.1
[16.12.2017 17:52:06] Java-Version: 1.8.0_151
[16.12.2017 17:52:06] Synchronisiere Kreditkarte 'LBB - Kreditkarte, IBAN DE8310..197900 [Landesbank Berlin - Berliner Sparkasse]'
[16.12.2017 17:52:06] Kein PIN vorhanden. Frage Benutzer nach PIN
[16.12.2017 17:52:11] Speichere eingegebene PIN für aktuelle Sitzung
[16.12.2017 17:52:11] Speichere eingegebene PIN permanent
[16.12.2017 17:52:13] Öffne Login-Seite der LBB...
[16.12.2017 17:52:14] Webseite der LBB kann nicht geöffnet werden.
[16.12.2017 17:52:14] Exception: TypeError: originalPage.getPageEncoding is not a function
[16.12.2017 17:52:14] TypeError: originalPage.getPageEncoding is not a function
	at fixErrorsOnHtmlPage (<eval>:1018)
	at lbb_login (<eval>:296)
	at lbb_sync (<eval>:175)
	at lbb_sync_account_statement (<eval>:133)
[16.12.2017 17:52:16] Synchronisierung der Kreditkarte 'LBB - Kreditkarte, IBAN DE8310..197900 [Landesbank Berlin - Berliner Sparkasse]' fehlgeschlagen.
[16.12.2017 17:52:16] Synchronisierung via Scripting erfolgreich beendet

little.yoda
Entwickler
Entwickler
Beiträge: 82
Registriert: Mi 18. Jun 2014, 23:00

Re: Webseite der LBB kann nicht geöffnet werden

Beitrag von little.yoda » Sa 16. Dez 2017, 17:57

Teste es bitte nochmal mit Htmlunit 2.27.

Ich bin mir ziemlich sicher, dass der gleiche Fehler dort nicht auftritt.
Bei mir läuft es mit der 2.27 und die Funktion, die dort an gemeckert wird, wurde erst mit der 2.28 entfernt.

qay
Beiträge: 25
Registriert: Di 18. Nov 2014, 18:05

Re: Webseite der LBB kann nicht geöffnet werden

Beitrag von qay » Sa 16. Dez 2017, 20:21

little.yoda hat geschrieben:Ich bin mir ziemlich sicher, dass der gleiche Fehler dort nicht auftritt.
Bei mir läuft es mit der 2.27 und die Funktion, die dort an gemeckert wird, wurde erst mit der 2.28 entfernt.
little.yoda: herzlich Dank für den Hinweis! Ich habe alle Testing Versionen rausgeworfen - alles läuft wieder. nicht nur LBB sondern auch Postsparkasse

Fijama
Beiträge: 5
Registriert: So 17. Jan 2016, 17:40

Re: Webseite der LBB kann nicht geöffnet werden

Beitrag von Fijama » Sa 23. Dez 2017, 11:24

Danke! Nach dem Downgrade auf htmlunit 2.27 geht es wieder!

MisterK
Moderator
Moderator
Beiträge: 77
Registriert: Di 5. Nov 2013, 15:12

Re: Webseite der LBB kann nicht geöffnet werden

Beitrag von MisterK » Sa 30. Dez 2017, 21:11

Jetzt sollte es auch mit HTMLUnit 2.28 gehen. Macht dafür einfach ein Update auf 0.23.

little.yoda
Entwickler
Entwickler
Beiträge: 82
Registriert: Mi 18. Jun 2014, 23:00

Re: Webseite der LBB kann nicht geöffnet werden

Beitrag von little.yoda » Sa 30. Dez 2017, 21:19

sieht gut aus. Bei mir funktioniert es. Danke

Zurück zu „Scripting-Plugin für LBB-/ADAC-/Amazon-Kreditkarten“