Java-Versionscheck unter 32-Bit Linux fehlerhaft

Hier gibt es Support zu den Plugin der neuesten Generation des Hibiscus-Mashup Projekts von Sebastian Richter
Wolfg43
Beiträge: 7
Registriert: Di 5. Nov 2019, 13:54

Java-Versionscheck unter 32-Bit Linux fehlerhaft

Beitrag von Wolfg43 » Di 2. Feb 2021, 12:20

Hallo Hibiscus-Scripter,

ich habe mit dem Rundum-Sorglos-Paket die jameica-Version von 2.8.6 auf 2.10.0 gewechselt. Nun kann ich bei der DKB nicht mehr meine VISA-Card-Umsätze abfragen.
Die Java-Vesion wird bemängelt.

Mein System:
Linux mit Lubuntu 18.4 LTS 32 bit
Sorglospaket dazu

Code: Alles auswählen

02.02.2021 09:34:22] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[02.02.2021 09:34:22]  
[02.02.2021 09:34:22] System-Info: OS[Linux (ver. 4.15.0-135-generic) i386]  Platform[Jameica 2.10.0 | Build: 480 vom 20201127]  Plugin[hibiscus 2.10.0 | Build: 361 vom 20201127]
[02.02.2021 09:34:22] Installierte und aktive Plugin-Versionen: [Finance.Websync ver. 0.9.21 | Build: 700 vom 20210125] [Hibiscus Mashup ver. 0.9.18 | Build: 440 vom 20210125]
[02.02.2021 09:34:22] Überprüfe Jameica-Version ...
[02.02.2021 09:34:22] OK: Jameica-Version 2.10.0 installiert und aktiv
[02.02.2021 09:34:22] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[02.02.2021 09:34:22] Fehler: Versionschecks fehlerhaft Achtung: Java-Version zu niedrig. Mindestens Version 1.8.161 wird benötigt. (aktuell verwendete Umgebung durch Jameica ist die Version 1.8.0-272)
Es wurde aber die aktuelle Version automatisch beim Setup installiert.

Code: Alles auswählen

1. Installiere Jameica 2.10.0 nach /opt ...
> Fertig

2. Integriere Java Runtime 8u272-b10 in Jameica ...
> Fertig

3. Installiere Hibiscus 2.10.0 in das aktuelle Benutzerverzeichnis ...
Wenn ich wieder zurück installiere auf jameica 2.8.6, funktiert alles.

Was mache ich falsch?

Gruß Wolfgang

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1694
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Visa DKB - jameica 2.10.0

Beitrag von Hibiscus-Scripter » Di 2. Feb 2021, 13:18

Hallo,

dein größter Fehler ist hier eindeutig der Einsatz eines 32-Bit Linux Betriebssystems.
Viele Sachen werden dafür nicht mehr weiter entwickelt oder einfach eingestellt. Wie eben Java oder auch der Chrome Browser.
Daher wirst du immer wieder massive Probleme bekommen und darauf hab ich dann auch keine Lust oder muss dir später sowieso sagen "Geht halt nicht, Pech gehabt"
:!: Von daher wäre der erste logische Tipp: Installiere ein 64-Bit Linux!

Aber:
danke für die ordentliche Meldung mit dem vollständigem Monitor-Log :thumbup:
Hierdurch hast du mir bereits viele nützliche Infos zukommen lassen.
Leider reichen diese dieses mal aber nicht zum direkten lösen des Problems.

Zur besseren Analyse benötige ich von dir eine vollständige TRACE-Log.
:idea: Hilfe hierzu gibst wie immer auch im Tipps und Tricks-Forum mit dem Punkt #2

Diese sendest du mir dann bitte am besten per PM (= Private Nachricht, oben rechts) als ZIP-Datei.

Gruß :wave:
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten (Der Post wird ansonsten gelöscht)

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum (Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website)

Wer ein Dankeschön für die Arbeit und Unkosten senden möchte, kann gerne auch :arrow: Spenden

Wolfg43
Beiträge: 7
Registriert: Di 5. Nov 2019, 13:54

Re: Java-Versionscheck unter 32-Bit Linux fehlerhaft

Beitrag von Wolfg43 » Di 2. Feb 2021, 21:54

Hallo Hibiscus-Scripter,
Die Logdatei habe ich per PM gesendet.
Gruß, Wofgang

Zurück zu „Hibiscus Mashup über Finance.Websync - (Beta 0.x = neue Release 3 der alten Scripte)“