Fehler: Versionschecks fehlerhaft: (JavaVersion 18)

Hier gibt es Support zu den Plugin der neuesten Generation des Hibiscus-Mashup Projekts von Sebastian Richter
UnbekannterNr1
Beiträge: 21
Registriert: Mi 19. Apr 2017, 16:56

Fehler: Versionschecks fehlerhaft: (JavaVersion 18)

Beitrag von UnbekannterNr1 » Di 22. Feb 2022, 17:59

Hallo,
ich bekomme seit neustem beim Abruf der Mashup Konten folgende Fehlermeldung:

Code: Alles auswählen

22.02.2022 17:53:49] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[22.02.2022 17:53:49]  
[22.02.2022 17:53:49] System-Info: OS[Linux (ver. 5.13.0-28-generic) amd64]  Platform[Jameica 2.11.0-nightly | Build: 479 vom 20211130]  Plugin[hibiscus 2.11.0-nightly | Build: 361 vom 20220222]
[22.02.2022 17:53:49] Installierte und aktive Plugin-Versionen: [Finance.Websync ver. 0.9.32 | Build: 795 vom 20220206] [Hibiscus Mashup ver. 0.9.21-nightly | Build: 481 vom 20220108]
[22.02.2022 17:53:49] Überprüfe Jameica-Version ...
[22.02.2022 17:53:49] OK: Jameica-Version 2.11.0 installiert und aktiv
[22.02.2022 17:53:49] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[22.02.2022 17:53:49] Fehler: Versionschecks fehlerhaft: (JavaVersion): java.lang.NumberFormatException: For input string: "18-ea"
	at java.base/jdk.internal.math.FloatingDecimal.readJavaFormatString(FloatingDecimal.java:2054)
	at java.base/jdk.internal.math.FloatingDecimal.parseFloat(FloatingDecimal.java:122)
	at java.base/java.lang.Float.parseFloat(Float.java:476)
	at de.derrichter.finance.websync.utils.check.JavaVersion.check(JavaVersion.java:163)
	at de.derrichter.hibiscus.mashup.crossover.websync.WebSynchronizeBackend$WebSyncJobGroup.sync(WebSynchronizeBackend.java:363)
	at de.willuhn.jameica.hbci.synchronize.AbstractSynchronizeBackend$Worker.run(AbstractSynchronizeBackend.java:399)
	at de.willuhn.jameica.gui.GUI$7.run(GUI.java:1081)
Installiert ist folgende Java Version:

Code: Alles auswählen

java -version
openjdk version "18-ea" 2022-03-15
OpenJDK Runtime Environment (build 18-ea+15-Ubuntu-4)
OpenJDK 64-Bit Server VM (build 18-ea+15-Ubuntu-4, mixed mode, sharing)
Bis vor 14 Tagen lief alles einwandfrei. Hat jemand einen Tipp für mich?

UnbekannterNr1
Beiträge: 21
Registriert: Mi 19. Apr 2017, 16:56

Re: Fehler: Versionschecks fehlerhaft: (JavaVersion)

Beitrag von UnbekannterNr1 » Fr 25. Feb 2022, 18:16

Hat da keiner einen Tipp für mich?

kunzol
Beiträge: 2
Registriert: So 27. Feb 2022, 15:33

Re: Fehler: Versionschecks fehlerhaft: (JavaVersion)

Beitrag von kunzol » So 27. Feb 2022, 16:00

Tipp: vorübergehend eine ältere Java Version benutzen, z.B. Version 15

UnbekannterNr1
Beiträge: 21
Registriert: Mi 19. Apr 2017, 16:56

Re: Fehler: Versionschecks fehlerhaft: (JavaVersion)

Beitrag von UnbekannterNr1 » Mo 28. Feb 2022, 22:11

So, mal zur Info. Ich habe jetzt auf java 17 zurück gerüstet, und jetzt läuft es wieder. Danke für den Tipp!

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1985
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Fehler: Versionschecks fehlerhaft: (JavaVersion)

Beitrag von Hibiscus-Scripter » Mo 6. Jun 2022, 21:31

So, danke für die ordentliche Meldung mit der vollständigen Status-Log :thumbup:
das Problem konnte zwar mit meiner Version 18 nicht reproduziert werden, aber ich hoffe ich konnte das Problem umgehen

Gerne mal mit den aktuellen Nightly-Builds von
  • finance.websync
  • hibiscus.mashup
ausprobieren, in welcher die Fehler behoben sein sollten.
:idea: Hilfe hierzu gibst wie immer auch im Tipps und Tricks-Forum


Hier dann bitte auch wieder Rückmeldung geben!
:!: Dabei bitte nicht vergessen:
Sollten dennoch weiterhin Fehler auftreten hier das vollständige Status-Log posten!
(formatiert wie in den Posting-Regeln beschrieben)


Gruß :wave:

Zurück zu „Hibiscus Mashup über Finance.Websync - (Beta 0.x = neue Release 3 der alten Scripte)“