[Erledigt] Update von Postbank-Plugins

Hier gibt es Support zu den Plugin der neuesten Generation des Hibiscus-Mashup Projekts von Sebastian Richter
prostetnik
Beiträge: 11
Registriert: So 15. Nov 2015, 14:25

[Erledigt] Update von Postbank-Plugins

Beitrag von prostetnik » Do 17. Nov 2016, 21:24

Hallo Skripter, hallo Leute,

erst einmal vielen Dank für dieses tolle Programm.

Ich habe ein Konto bei der Postbank mit Visa.
Und Paypal.
Entsprechend läuft bei mir jameica mit den scripten seit ca. einem Jahr:
hibiscus v2.6.17 (jetzt v2.6.18)
hibiscus.scripting.htmlunit v2.18 (jetzt v2.23)
hibiscus.script.postbanktask v2.1.10
hibiscus.script.paypal v2.1.10

Da ich mit dem Abruf der VISA-Umsätze Probleme habe, wollte ich nun alles updaten.
Zwei der Scripte konnte ich mit jameica (?) selbst updaten (s.o.).
Jedoch habe ich bereits seit Monaten mehrere Anläufe unternommen, bin aber hier zunehmenst verwirrter... was ich wie installieren muss usw.

*Meine Umsatz-Daten sollen natürlich alle erhalten bleiben.*

Ich habe zwar auch versucht finance.websync und hibiscus.mashup zu installieren.
Es gab aber dann mit anderen Scripten eine Fehlermeldung.
Muss ich vorab hibiscus.script.postbanktask deinstallieren?
Oder noch weitere?
Kann ich nach dem Update meine aktuellen Umsatz-Listen weiterführen?

Gibt es irgendwo ein howto oder eine Beschreibung der chronologischen Vorgehensweise für ein solches Update.
Bin schon ganz meschugge.

mit freundlichem Gruß
prostetnik

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1616
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Update von Plugins

Beitrag von Hibiscus-Scripter » Do 17. Nov 2016, 21:41

und die Installations-Anleitung gleich hier im Forum zur Release 3 reicht dir nicht?
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten (Der Post wird ansonsten gelöscht)

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum (Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website)

Wer ein Dankeschön für die Arbeit und Unkosten senden möchte, kann gerne auch :arrow: Spenden

prostetnik
Beiträge: 11
Registriert: So 15. Nov 2015, 14:25

Re: Update von Plugins

Beitrag von prostetnik » Do 17. Nov 2016, 23:43

Wenn Du diese meinst

http://scripting-forum.derrichter.de/vi ... =192#p1529

dann nicht, weil sie ja meine Fragen nicht beantwortet.

Bedenke bitte, dass diese Dinge für Dich selbstverständlich sind - für mich aber Neuland.
Muss ich denn vorher irgendwelche Scripte deinstallieren?

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1616
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Update von Plugins

Beitrag von Hibiscus-Scripter » Fr 18. Nov 2016, 07:59

genau die meinte ich, was fehlt dir denn da als Info?

Du musst halt grob gesagt mit den angegebenen Bedienungen (Java z. B.) einfach "finance.websync" und "hibiscus.mashup" installieren. Diese bilden die Release 3 und ersetzen voll automatisch die Scripte der Release 2.
Installieren, fertig ... (Die Anleitung ist da chronologisch komplett, erst vor ein paar Tagen war wieder einer hier der die aber auch einfach nicht gelesen hat :roll: )

Kontoeinstellungen werden automatisch angefasst und die Daten (Umsatzlisten) werden natürlich nicht berührt ... steht aber alles soweit auch in der Install-Anleitung die du ja gelesen hast ...

Wenn du dabei Fehler erhältst obwohl die angegebenen Voraussetzungen erfüllt sind dann poste doch hier nach den Posting-Regeln auch das komplette Monitor-Log, denn die Aussage "Ich erhalte einen Fehler" bringt keinen weiter denn ich kann nicht hell-sehen ...

Wenn dir die manuelle Methode zu kompliziert ist verwende doch das Rund-um-Sorglos-Paket ...
(falls hier dein Benutzerverzeichnis vom Standard abweicht können wir ja wieder helfen bei der "Migration") oder du benennst das Benutzerverzeichnis vorher einfach in den üblichen Standard um --> http://hibiscus-scripting.derrichter.de ... stallation

Gruß
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten (Der Post wird ansonsten gelöscht)

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum (Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website)

Wer ein Dankeschön für die Arbeit und Unkosten senden möchte, kann gerne auch :arrow: Spenden

prostetnik
Beiträge: 11
Registriert: So 15. Nov 2015, 14:25

Re: Update von Plugins

Beitrag von prostetnik » Fr 25. Nov 2016, 22:03

Hallo Hibiscus-Scripter,

danke für Deine Antwort.
Erst heute konnte ich es noch einmal probieren.
An Update, bzw. Installation habe ich einzeln folgendes gemacht:

hibiscus 2.6.17 auf 2.6.18
hibiscus.scripting.htmlunit auf die neuste Version
finanz.websync 0.7.13
hibiscus.mashup 0.7.13

Starte ich jetzt, bekomme ich die Fehlermeldung
Script nicht lesbar für:

hibiscus.script.paypal.js
und
hibsicus.script.postbanktask.js

folglich habe ich beide Scripte über "Scripte konfigurieren" entfernt.

Nun startet jameica ohne Fehlermeldung.
Posbank-Kto
Paypal
lassen sich auslesen.

Postbak-Visa ergibt
Fehler: kein passendes Script gefunden

Habe ich da etwas überlesen?
Ich meine gelesen zu haben, dass Visa funktioniert.

gruß
prostetnik

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1616
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Update von Plugins

Beitrag von Hibiscus-Scripter » Sa 26. Nov 2016, 00:52

soweit alles richtig ...

das die alten Scripte nicht ordentlich ausgetragen werden ist mir gestern auch aufgefallen ... da muss ich mal nach einem Fehler schauen ....
genauso wird wohl durch die radikale Umstellung ein Postbank-Kreditkarten Konto nicht richtig umkonfiguriert ...

Dies kann man manuell anpassen wenn man möchte:

Bezeichnung des Kontos - frei wählbar
Kontoinhaber - frei wählbar
Kundennummer - Ihre Kontonummer des Girokontos oder des verwendeten Kontos der Postbank
(es handelt sich hier um die Kontonummer welche bei der Anmeldung benutzt wird)
(nicht der Benutzername da dieser hier nicht eingegeben werden kann)
Kontonummer - 0444333500 (am besten genau diese angeben - =Kontonummer für Einzahlungen)
Unterkontonummer - Ihre Kreditkartennummer (vollständig)
(alles einsehbar im Online-Banking unter Umsätze, in jedem Fall so anzugeben wie dort)
Bankleitzahl - eine dieser möglichen Bankleitzahlen der Postbanken im Script:
(welche hiervon verwendet wird ist technisch irrelevant)
10010010 - Postbank Berlin
44010046 - Postbank Dortmund
36010043 - Postbank Essen
50010060 - Postbank Fankfurt am Main
25010030 - Postbank Hannover
20010020 - Postbank Hamburg
20110022 - Postbank Hamburg - (wird bei Spar-Konten verwendet)
66010075 - Postbank Karlsruhe
37010050 - Postbank Köln
86010090 - Postbank Leipzig - (wird bei Tagesgeld-Konten verwendet)
54510067 - Postbank Ludwigshafen
70010080 - Postbank München
70110088 - Postbank München - (wird bei Spar-Konten verwendet)
76010085 - Postbank Nürnberg
59010066 - Postbank Saarbrücken - (wird bei Tagesgeld-Konten verwendet)
60010070 - Postbank Stuttgart
Verfahren - non-HBCI (Hibiscus Mashup)
Offline-Konto - bei dieser Checkbox ist kein Haken zu setzen
> Synchronisierungsoptionen
Passende Gegenbuchungen automatisch anlegen
- bei dieser Checkbox ist der Haken zu entfernen um zu vermeiden dass Überweisungen


Oder falls z. B. das Konto gelöscht werden kann weil z. B. keine Kategorien besetzt wurden. Dann das Konto einfach mal löschen und/oder mit Hilfe des Kontoanlage-Assistenten im Mashup-Menüpunkt ein neues Konto für eine Kreditkarte der Postbank anlegen ...

Gruß
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten (Der Post wird ansonsten gelöscht)

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum (Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website)

Wer ein Dankeschön für die Arbeit und Unkosten senden möchte, kann gerne auch :arrow: Spenden

prostetnik
Beiträge: 11
Registriert: So 15. Nov 2015, 14:25

Re: Update von Plugins

Beitrag von prostetnik » Sa 26. Nov 2016, 14:06

Hallo Hibiscus-Scripter,

danke für Deine ausführliche Antwort.
Bin nun vermutlich schon einen Schritt weitergekommen.
Folgende Einstellungen habe ich nun vorgenommen.

Kundenkennung: [meine Kto-Nr]
Kontonummer: 0444333500
Bankleitzahl: 10010010
Unterkontonummer: [Kreditkartennummer] mit Leerzeichen oder ohne - habe beides ausprobiert
Zugangsweg: non-HBCI (Hibiscus Mashup)
Verfahren: [auf bitte wählen gelassen] oder [PIN/TAN Web (non-HBCI)] beide Einstellungen führen zu u. g. Ergebnis
IBAN: DE35 3701 0050 0444 3335 00 hier habe ich auch meine IBAN versuchsweise eingetragen - beide Einstellungen führen zu u. g. Ergebnis
BIC: PBNKDEFFXXX

Offline-Konto: keine Markierung
Synchrionisierungsoptionen: "Saldo abrufen" und "Umsätze abrufen" markiert

gehe ich auf "saldo und Umsätze abrufen"
kann ich meine PIN eigeben und dann gibt es u. g. Statusmeldungen.


Testweise bin ich nun über den Browser ins Konto gegangen.
Da sind bei dem Auswahlmenü "Umsätze anzeigen" für [Kontoauswahl (VISA-Nr.)] die letzten beiden Zahlen durch zwei Nullen ersetzt.

Kann das der Fehler sein?
Alles andere scheint ja funktioniert zu haben - liegt es evtl. an der Website der Postbank?

Übrigens stand in der alten Konfiguration von Hibiscus bei "Unterkontonummer" nur die mittleren zwei Zahlenblöcke. Das habe ich aber auch schon ausprobiert.
Damit gibt es erst gar keine PIN-Abfrage sondern gleich die Statusmeldung:
"Institut und Kontokonfiguration im non-HBCI Backend nicht gefunden! Einstellungen nicht korrekt oder Abruf nicht unterstüzt"

gruß
prostetnik

Ergänzung:
Habe eben mit Postbank/Visa telefoniert.
Diese Anzeige mit dem letzten Ziffernblock ist normal

Code: Alles auswählen

26.11.2016 13:36:14] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[26.11.2016 13:36:14]  
[26.11.2016 13:36:14] System-Info: OS[Linux (ver. 4.1.34-33-default) amd64]  Platform[Jameica 2.6.4 Build: 441]  Plugin[hibiscus 2.6.18 Build: 361]
[26.11.2016 13:36:14] Installierte und aktive PlugIn-Versionen: [Finance.Websync ver. 0.7.13 - Build 205] [Hibiscus Mashup ver. 0.7.13 Build 155]
[26.11.2016 13:36:14] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[26.11.2016 13:36:14] OK: Java-Version 1.8.0_101 von 'Oracle Corporation' installiert, aktiv und verwendet Zeichensatz 'UTF-8' (Home: /usr/lib64/jvm/java-1.8.0-openjdk-1.8.0/jre)
[26.11.2016 13:36:14] Überprüfe HTMLUnit-Version ...
[26.11.2016 13:36:14] OK: HTMLUnit-Version 2.23 installiert und aktiv
[26.11.2016 13:36:14]  
[26.11.2016 13:36:14] Synchronisiere Konto: Postbank - Kreditkarte, Kto. 0444333500 [Postbank]
[26.11.2016 13:36:14] Web-Login mit Anmeldekennung [XXXX]******* auf https://banking.postbank.de/rai/login ...
[26.11.2016 13:36:26] Postbank-Login war erfolgreich
[26.11.2016 13:36:26] Rufe Umsatzübersicht auf und starte Abruf des Kontoauszuges ...
[26.11.2016 13:36:26] Suche Umsätze im Zeitraum vom 11.11.2016 bis 26.11.2016 und lese diese aus ...
[26.11.2016 13:36:33] Web-Logout der aktuellen Online-Sitzung ...
[26.11.2016 13:36:33] Postbank-Logout war erfolgreich
[26.11.2016 13:36:33] Kreditkarte ****[XXXXXXXX]**** in der Kontoauswahl nicht gefunden! Kontrollieren Sie bitte Ihre Angaben

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1616
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Update von Plugins

Beitrag von Hibiscus-Scripter » Sa 26. Nov 2016, 14:53

Hibiscus-Scripter hat geschrieben: (alles einsehbar im Online-Banking unter Umsätze, in jedem Fall so anzugeben wie dort)
halte dich doch einfach an die Daten-Anleitung ... dann beantwortest du dir alle Fragen selbst ...

und bitte halte dich an die Postin-Regeln!
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten (Der Post wird ansonsten gelöscht)

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum (Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website)

Wer ein Dankeschön für die Arbeit und Unkosten senden möchte, kann gerne auch :arrow: Spenden

prostetnik
Beiträge: 11
Registriert: So 15. Nov 2015, 14:25

Re: Update von Plugins

Beitrag von prostetnik » Sa 26. Nov 2016, 14:54

...so!
Jetzt habe ich noch einmal bei "Unterkontonummer" die letzten Ziffern durch Nullen ersetzt.
Nun funktionierte es plötzlich.

Leider gab es dann wohl eine Unstimmigkeit mit dem Saldo - ich vermute deswegen, weil die letzten Daten vom 01.08.16 waren, d.h. zwischendurch nicht mehr abgerufen werden konnte.
Ein "Nein" (ich hatte nichts gelöscht) übertrug die Daten.
Aber leider falsch.
Habe gerade gesehen, dass Du/Sie mir eben geantwortet haben.
Mal schauen.

prostetnik
Beiträge: 11
Registriert: So 15. Nov 2015, 14:25

Re: Update von Postbank-Plugins

Beitrag von prostetnik » Sa 26. Nov 2016, 15:01

t'schuldigung!
Vermute, Du meinst den Code-Block

Zurück zu „Hibiscus Mashup über Finance.Websync - (Beta 0.x = neue Release 3 der alten Scripte)“