[Geschlossen] Mashup Versionsfehler mit Java 10

Hier gibt es Support zu den Plugin der neuesten Generation des Hibiscus-Mashup Projekts von Sebastian Richter
dip
Beiträge: 7
Registriert: Mo 20. Feb 2017, 21:46

[Geschlossen] Mashup Versionsfehler mit Java 10

Beitrag von dip » Fr 6. Jul 2018, 01:05

Ich habe gerade mein Linux-Mint System von 18.3 auf 19 aktualisiert.
Jetzt bekomme ich in Hibiscus beim Abrufen meiner Konten, die über Mashup abgerufen werden, die Fehlermeldung "Versionschecks fehlerhaft".

Anscheinend liegt das an der installierten Java-Version. In Linux-Mint 19 ist OpenJDK 11 standardmäßig installiert (das verwendet die java 10 version). Da OpenJDK 8 auch noch installiert ist, habe ich herausgefunden, dass ich mit "sudo update-alternatives --config java" die version 8 als standard einstellen kann und dann funktioniert der Abruf mit Mashup auch wieder.

Ich würde aber gerne den Standard wieder auf OpenJDK 11 einstellen. Kann ich irgendwie einstellen, dass nur für Hibiscus die OpenJDK 8 verwendet wird? Oder wird Mashup bald aktualisiert, dass es auch mit OpenJDK 11 funktioniert?

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1193
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Mashup Versionsfehler mit Java 10

Beitrag von Hibiscus-Scripter » Fr 6. Jul 2018, 10:48

Hallo,

Du musst Java 8 verwenden. Java 10 ist noch nicht offiziell als Final-Stable veröffentlicht und wird daher auch nicht von meinen Plugins unterstützt. (von Java 9 wollte ich schon fasst das selbe schreiben, so schnell konnte man gar nicht schauen wie das schon wieder vom Markt ist, was mir also recht gibt ;) )
Zur Info: Ich halte mich da eigentlich an die Veröffentlichung für Endanwender unter Java.com, dort steht immer noch die Java 8 Patch 171.
(OpenJDK wird von mir sowieso offiziell nicht unterstützt sondern nur Oracle Java)

Aber da du mich nachnach fragst.
Mit meinem Rund-um-Sorglos Paket (oder derren User) hat man eben genau dieses Problem nicht, da dort ja Java mit integriert ist und somit auf dem System selbst gar kein Java installiert sein muss oder wie in deinem Fall, egal ist welches da noch läuft.
Wenn du dies selbst umsetzen willst:
Musst du in dem Startscript "jameica.sh" sowas mitangeben wie

Code: Alles auswählen

 exec javaruntime/bin/java
Relativer Pfad, gesehen aus Sicht des Startscripts. (In meinem Install-Paket liegt also nach der Installation im Hauptorder von Jameica ein Ordner "javaruntime" indem die JRE extrahiert wurde.

Gruß

PS: bitte verwende bei deinen Beiträgen sowas wie Absätze, also Formatierungen ... Danke
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

dip
Beiträge: 7
Registriert: Mo 20. Feb 2017, 21:46

Re: Mashup Versionsfehler mit Java 10

Beitrag von dip » Mo 9. Jul 2018, 01:21

Danke, ich werde das mit dem exec mal ausprobieren. Ich dachte eigentlich, ich hätte ursprünglich die rundum sorglos Variante installiert. Ist aber schon einige Zeit her und so genau weiß ich das nicht mehr.

Viele Grüße
Dieter

Neonof
Beiträge: 1
Registriert: Sa 28. Jul 2018, 10:19

Hibiscus Mashup - Java Versionsfehler beim Abrufen der PayPal-Umsätze

Beitrag von Neonof » Sa 28. Jul 2018, 10:30

Hallo,

wie im Titel beschrieben erhalte ich beim Abrufen von PayPal Saldo und Umsätzen folgenden Fehler:

Ich habe mir gestern erst alles eingerichtet, daher sind die Plugins alle auf dem aktuellen Stand.
(Außer vielleicht die bereits zuvor installierte Java JRE (1.8.0_171), aber soweit ich gesehen habe, stellt Jameica (2.8.0) wohl eine eigene zur Verfügung?
Wie löse ich das denn am besten?

Danke schon einmal für Hilfe!

Gruß,
Neonof

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1193
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Mashup Versionsfehler mit Java 10

Beitrag von Hibiscus-Scripter » Sa 28. Jul 2018, 11:06

Um das hier nochmals ganz klar zu sagen:

Hier wird immer mein Rund-um-Sorglos Paket zur Installation empfohlen, da dort ein passendes Java enthalten ist!
Wer Jameica und Co. selbst manuell entpackt und somit installiert, der muss sich auch um ein passendes Java auf seinem System kümmern!
(siehe oben)

Gruß
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

dip
Beiträge: 7
Registriert: Mo 20. Feb 2017, 21:46

Re: Mashup Versionsfehler mit Java 10

Beitrag von dip » So 29. Jul 2018, 00:11

Ich habe jetzt einfach das Rundum-Sorglos-Paket nochmals installiert und jetzt funktioniert alles ohne Probleme und ohne, dass ich die Java-Version manuell umstellen muss. Alle Einstellungen sind dabei erhalten geblieben. :D
Vielen Dank

PS: Der Link zum Rundum-Sorglos-Paket im letzten Post funktioniert nicht. Am Ende muss es "download" statt "downloads" heißen.

magic
Beiträge: 28
Registriert: Fr 3. Apr 2015, 21:19

Fehler abeim Konto aktuallisieren via Mashup

Beitrag von magic » Di 11. Dez 2018, 22:43

Hallo,

wenn ich ein "Mashup"-Konto aktualisieren möchte erhalte ich folgende Fehlermeldung:

Mit java --version
openjdk 10.0.2 2018-07-17
OpenJDK Runtime Environment (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.4)
OpenJDK 64-Bit Server VM (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.4, mixed mode)

Code: Alles auswählen

[11.12.2018 22:37:09] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[11.12.2018 22:37:09]  
[11.12.2018 22:37:09] System-Info: OS[Linux (ver. 4.15.0-42-generic) amd64]  Platform[Jameica 2.8.2 | Build: 450 vom 20180917]  Plugin[hibiscus 2.8.6 | Build: 369 vom 20181101]
[11.12.2018 22:37:09] Installierte und aktive PlugIn-Versionen: [Finance.Websync ver. 0.9.1 | Build: 417 vom 20181101] [Hibiscus Mashup ver. 0.9.1 | Build: 323 vom 20181101]
[11.12.2018 22:37:09] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[11.12.2018 22:37:09] Fehler: Versionschecks fehlerhaft: 1
bzw. mit java --version
java 11.0.1 2018-10-16 LTS
Java(TM) SE Runtime Environment 18.9 (build 11.0.1+13-LTS)
Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.1+13-LTS, mixed mode)

Code: Alles auswählen

[11.12.2018 22:42:07] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[11.12.2018 22:42:07]  
[11.12.2018 22:42:07] System-Info: OS[Linux (ver. 4.15.0-42-generic) amd64]  Platform[Jameica 2.8.2 | Build: 450 vom 20180917]  Plugin[hibiscus 2.8.6 | Build: 369 vom 20181101]
[11.12.2018 22:42:07] Installierte und aktive PlugIn-Versionen: [Finance.Websync ver. 0.9.1 | Build: 417 vom 20181101] [Hibiscus Mashup ver. 0.9.1 | Build: 323 vom 20181101]
[11.12.2018 22:42:07] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[11.12.2018 22:42:07] Fehler: Versionschecks fehlerhaft: Index 1 out of bounds for length 1
Es werden keine neuen Updates angezeigt in Jameica...
Ist da ein Fehler, oder mache ich was falsch?

Gruß
Maik

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1193
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: [Geschlossen] Mashup Versionsfehler mit Java 10

Beitrag von Hibiscus-Scripter » Mi 12. Dez 2018, 08:06

Bitte nicht immer neue Threads für bereits hier im Forum mehrfach angesprochene Themen eröffnen, es gibt eine Suche in der man die Fehlermeldung wunderbar findet.

Und nochmals Java 8 ist aktuell,
eine Version 9 oder 10 wird gar nicht mehr gepflegt und eine Version 10 oder 11 sind noch nie offiziell als Stable veröffentlicht worden!

Ich halte mich immer an java.com und die dort angebotene Version, aktuell 1.8.0_191
Zudem gibt es ja auch Abhängigkeiten mit anderen Komponenten oder z. B. den WebDrivern.

Warum hier immer wieder Leute auch eine sozusagen Test-Version oder nicht mehr gepflegte Version (wie bei 9 und 10) von Java einsetzen möchten werde ich wohl auch nicht verstehen, daher von mir bei dessen Einsatz keinerlei support!

Wem das nicht gefällt dem rate ich wie hier beschrieben zu meinem Rund-um-sorglos-Paket oder dazu sich selbst damit zu beschäftigen wie man Jameica mit einer beliebigen Java-Installation starten kann, auch hier beschrieben, womit das Thema keines mehr wäre.

Gruß

PS: Daher bitte ich darum das Thema nun bis zur offiziellen Release auch ruhen zu lassen, ansonsten werden Beiträge entfernt und Benutzer gesperrt die es nicht sein lassen können
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

Zurück zu „Release 3 - Finance.Websync & Hibiscus Mashup - (Beta 0.x)“