[Erledigt] VW Bank - Umsätze werden nicht abgerufen

Hier gibt es Support zu den Plugin der neuesten Generation des Hibiscus-Mashup Projekts von Sebastian Richter
andy
Beiträge: 5
Registriert: Fr 30. Aug 2019, 16:05

[Erledigt] VW Bank - Umsätze werden nicht abgerufen

Beitrag von andy » Fr 30. Aug 2019, 16:12

Hi,

die Anmeldung funktioniert, danach kommt die Meldung "Fehler: Download-Datei nicht gefunden (get lastFileModified = null). Bitte versuchen Sie es nochmals"

Code: Alles auswählen

[30.08.2019 16:07:13] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[30.08.2019 16:07:13]  
[30.08.2019 16:07:13] System-Info: OS[Windows 10 (ver. 10.0) x86]  Platform[Jameica 2.8.4 | Build: 453 vom 20190211]  Plugin[hibiscus 2.8.13 | Build: 377 vom 20190624]
[30.08.2019 16:07:13] Installierte und aktive PlugIn-Versionen: [Finance.Websync ver. 0.9.5 | Build: 480 vom 20190823] [Hibiscus Mashup ver. 0.9.5 | Build: 350 vom 20190823]
[30.08.2019 16:07:13] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[30.08.2019 16:07:13] OK: Java-Version 1.8.0_221 von 'Oracle Corporation' installiert, aktiv und verwendet Zeichensatz 'Cp1252' (Home: C:\Program Files (x86)\Jameica\javaruntime)
[30.08.2019 16:07:13] Überprüfe Selenium-Version ...
[30.08.2019 16:07:13] OK: Selenium-Version 3.141.59 installiert und aktiv
[30.08.2019 16:07:13] Überprüfe ChromeDriver-Version ...
[30.08.2019 16:07:13] OK: ChromeDriver-Version 76.0.3809.126 installiert und aktiv
[30.08.2019 16:07:13]  
[30.08.2019 16:07:13] Synchronisiere Konto 'VWBank - Online, IBAN DE1027..803472 [Volkswagen Bank]' ...
[30.08.2019 16:07:18] Überprüfe Chromium-Version ...
[30.08.2019 16:07:18] OK. Browser ist: chrome ver. 76
[30.08.2019 16:07:23] Web-Login mit Selenium-WebDriver-Engine mit Anmeldekennung 0774******* auf https://banking.vwfs.de/PBODE-FE-UI/#/login ...
[30.08.2019 16:07:39] VWBank-Login war erfolgreich
[30.08.2019 16:07:39] Rufe Umsatzübersicht auf und starte Abruf des Kontoauszuges ...
[30.08.2019 16:07:39] Sie benutzen dieses Konto das erste Mal in Hibiscus oder der Saldo und das Datum wurden zurückgesetzt ...
[30.08.2019 16:07:39] ... es werden daher nun alle möglichen Umsätze abgerufen ...
[30.08.2019 16:07:39] Suche Umsätze im Zeitraum vom 06.06.2018 bis 30.08.2019 und lese diese aus ...
[30.08.2019 16:08:08] Web-Logout der aktuellen Online-Sitzung ...
[30.08.2019 16:08:12] VWBank-Logout war erfolgreich
[30.08.2019 16:08:13] Fehler: Download-Datei nicht gefunden (get lastFileModified = null). Bitte versuchen Sie es nochmals
Updates sind aktuell. Genutzt wurde das Rundum Sorglos Paket in den jeweiligen Versionen (x64 und x86 Version getestet)

Jameica.log (DEBUG aktiv) habe ich erstellt und kann ich bei Bedarf per PM senden.

Danke & Gruß,
Andy

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1278
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: VW Bank - Umsätze werden nicht abgerufen

Beitrag von Hibiscus-Scripter » Fr 30. Aug 2019, 17:34

hmm, seltsam, konnte gerade in diesem Moment ohne Probleme abrufen, sonst noch jemand mit dem Fehler?

Ansonsten benötige ich daher wohl eine vollständige TRACE-Log per PM, wie in den Posting-Regeln (Punkt 2 b) beschrieben, um mir das genauer ansehen zu können.

Gruß
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

andy
Beiträge: 5
Registriert: Fr 30. Aug 2019, 16:05

Re: VW Bank - Umsätze werden nicht abgerufen

Beitrag von andy » Sa 31. Aug 2019, 00:05

Hibiscus-Scripter hat geschrieben:
Fr 30. Aug 2019, 17:34
hmm, seltsam, konnte gerade in diesem Moment ohne Probleme abrufen, sonst noch jemand mit dem Fehler?

Ansonsten benötige ich daher wohl eine vollständige TRACE-Log per PM, wie in den Posting-Regeln (Punkt 2 b) beschrieben, um mir das genauer ansehen zu können.

Gruß
Ich kann das auch nicht nachvollziehen.
Hab dir die TRACE-Log per PM gesendet.

Danke & Gruß,
Andy

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1278
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: VW Bank - Umsätze werden nicht abgerufen

Beitrag von Hibiscus-Scripter » Sa 31. Aug 2019, 13:03

Aber du könntest mal bitte in dem Konto genau das durchmachen was das Plugin auch macht, also in genau dem gleichen Konto nach den Umsätzen in in genau dem gesuchten Zeitraum filtern und dann die Transaktionen herunterladen/exportieren mit dem Button rechts daneben im Online-Banking klicken und beobachten was dann genauesten passiert.
Läd er da eine Datei runter, oder hatte er in den Zeitraum überhaupt Umsätze gefunden?
Also ich müsste auch noch wissen ob in den Zeitraum in dem das Plugin versucht abzurufen, überhaupt Umsätze vorhanden sind.

Gruß
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

andy
Beiträge: 5
Registriert: Fr 30. Aug 2019, 16:05

Re: VW Bank - Umsätze werden nicht abgerufen

Beitrag von andy » Sa 31. Aug 2019, 19:56

Hibiscus-Scripter hat geschrieben:
Sa 31. Aug 2019, 13:03
Aber du könntest mal bitte in dem Konto genau das durchmachen was das Plugin auch macht, also in genau dem gleichen Konto nach den Umsätzen in in genau dem gesuchten Zeitraum filtern und dann die Transaktionen herunterladen/exportieren mit dem Button rechts daneben im Online-Banking klicken und beobachten was dann genauesten passiert.
Läd er da eine Datei runter, oder hatte er in den Zeitraum überhaupt Umsätze gefunden?
Also ich müsste auch noch wissen ob in den Zeitraum in dem das Plugin versucht abzurufen, überhaupt Umsätze vorhanden sind.

Gruß
Abruf im Zeitraum 06.06.2018 - 30.08.2019 hat im Banking mit Chrome sowie Firefox funktioniert und die CSV wurde bereitgestellt.
In der CSV sind die Umsätze ab 06.06.18 gelistet (1122 Einträge).
Hab bei der VW Bank seit ~ 06/2015 mein Girokonto und nutze das seitdem für alles. Umsätze sind reichlich vorhanden.

Gruß & schönes Wochenende,
Andy

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1278
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: VW Bank - Umsätze werden nicht abgerufen

Beitrag von Hibiscus-Scripter » So 1. Sep 2019, 12:10

OK, dann wirds interessant, hab mal für dich als Test die Wartezeiten extrem hochgesetzt um das auszuschließen, aber das kriegen wir...

Gerne mal mit den aktuellen Nightly-Builds von
  • finance.websync
  • hibiscus.mashup
ausprobieren, in welcher die Fehler behoben sein sollten.
:idea: Hilfe hierzu gibst wie immer auch im Tipps und Tricks-Forum


Hier dann bitte auch wieder Rückmeldung geben!
:!: Dabei bitte nicht vergessen:
Sollten dennoch weiterhin Fehler auftreten hier das vollständige Monitor-Log posten!
(formatiert wie in den Posting-Regeln beschrieben)


Gruß

andy
Beiträge: 5
Registriert: Fr 30. Aug 2019, 16:05

Re: VW Bank - Umsätze werden nicht abgerufen

Beitrag von andy » Mo 2. Sep 2019, 18:26

Hat funktioniert. Der Abruf war jetzt möglich und beinhaltet 1125 Umsätze.

Vielen Dank.

Gruß,
Andy

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1278
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: VW Bank - Umsätze werden nicht abgerufen

Beitrag von Hibiscus-Scripter » Fr 6. Sep 2019, 00:30

So, habe jetzt einfach eine längere Wartezeit bei einem Komplett-Abruf eingebaut.

Wenn du willst, könntest du das nochmals testen, wieder mit der aktuellen Nightly-Build wie oben beschrieben, indem du mal alle Umsätze nochmals löscht und dann zweimal abrufst?

Danke
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

andy
Beiträge: 5
Registriert: Fr 30. Aug 2019, 16:05

Re: VW Bank - Umsätze werden nicht abgerufen

Beitrag von andy » So 8. Sep 2019, 19:35

Hibiscus-Scripter hat geschrieben:
Fr 6. Sep 2019, 00:30
So, habe jetzt einfach eine längere Wartezeit bei einem Komplett-Abruf eingebaut.

Wenn du willst, könntest du das nochmals testen, wieder mit der aktuellen Nightly-Build wie oben beschrieben, indem du mal alle Umsätze nochmals löscht und dann zweimal abrufst?

Danke
Konto gelöscht (inkl. allen Umsätzen), neu eingerichtet und Abruf 15.06.2019 - heute erfolgreich. Das Ganze habe ich 2x gemacht.
Beim löschen und neuanlegen in einer Sitzung (also ohne Neustart der Anwendung) kommt es zum ursprünglichen Fehler.

Gruß,
Andy

Zurück zu „Release 3 - Finance.Websync & Hibiscus Mashup - (Beta 0.x)“