[Erledigt] Leaseplan Bank - Fehler beim Setzen des Login-Formulars oder der Felder

Hier gibt es Support zu den Plugin der neuesten Generation des Hibiscus-Mashup Projekts von Sebastian Richter
nirbhay
Beiträge: 27
Registriert: Mi 2. Sep 2015, 17:17

[Erledigt] Leaseplan Bank - Fehler beim Setzen des Login-Formulars oder der Felder

Beitrag von nirbhay » Do 5. Sep 2019, 13:50

Mein letzter erfolgreicher Umsatzabruf bei der Leaseplan Bank war am 03.09.2019, 15:34.
Heute fällt mir auf, dass der Abruf auf einen Fehler läuft. Es folgt der Monitor-Log:

Code: Alles auswählen

[05.09.2019 13:40:43] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[05.09.2019 13:40:43]  
[05.09.2019 13:40:43] System-Info: OS[Windows 7 (ver. 6.1) amd64]  Platform[Jameica 2.8.4 | Build: 453 vom 20190211]  Plugin[hibiscus 2.8.13 | Build: 377 vom 20190624]
[05.09.2019 13:40:43] Installierte und aktive PlugIn-Versionen: [Finance.Websync ver. 0.9.5-nightly | Build: 484 vom 20190901] [Hibiscus Mashup ver. 0.9.5-nightly | Build: 352 vom 20190826]
[05.09.2019 13:40:43] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[05.09.2019 13:40:43] OK: Java-Version 1.8.0_221 von 'Oracle Corporation' installiert, aktiv und verwendet Zeichensatz 'Cp1252' (Home: C:\Program Files\Java\jre1.8.0_221)
[05.09.2019 13:40:43] Überprüfe Selenium-Version ...
[05.09.2019 13:40:43] OK: Selenium-Version 3.141.59 installiert und aktiv
[05.09.2019 13:40:43] Überprüfe ChromeDriver-Version ...
[05.09.2019 13:40:43] OK: ChromeDriver-Version 76.0.3809.126 installiert und aktiv
[05.09.2019 13:40:43] Überprüfe PDFBox-Version ...
[05.09.2019 13:40:43] OK: PDFBox-Version 2.0.16 installiert und aktiv
[05.09.2019 13:40:43]  
[05.09.2019 13:40:43] Synchronisiere Konto 'Leaseplan Bank, IBAN NL62LP..077751 [BIC: NL62LPLNXXX]' ...
[05.09.2019 13:40:46] Überprüfe Chromium-Version ...
[05.09.2019 13:40:46] OK. Browser ist: chrome ver. 76
[05.09.2019 13:40:48] Web-Login mit Selenium-WebDriver-Engine mit Anmeldekennung nirb******* auf https://sparen.leaseplanbank.de/ ...
[05.09.2019 13:41:00] Fehler: Web-Login mit Selenium-WebDriver fehlgeschlagen! Fehler beim Setzen des Login-Formulars oder der Felder (siehe Log - Bitte den Entwickler im Forum informieren)
Log-Eintrag: org.openqa.selenium.NoSuchElementException: no such element: Unable to locate element: {"method":"xpath","selector":"//button[@type='submit' and @title='Log in']"}
  (Session info: headless chrome=76.0.3809.132)
For documentation on this error, please visit: https://www.seleniumhq.org/exceptions/no_such_element.html
Build info: version: '3.141.59', revision: 'e82be7d358', time: '2018-11-14T08:25:48'
System info: host: 'ACER', ip: '192.168.255.54', os.name: 'Windows 7', os.arch: 'amd64', os.version: '6.1', java.version: '1.8.0_221'
Driver info: org.openqa.selenium.chrome.ChromeDriver
Capabilities {acceptInsecureCerts: false, browserName: chrome, browserVersion: 76.0.3809.132, chrome: {chromedriverVersion: 76.0.3809.126 (d80a294506b4..., userDataDir: C:\Users\swami\AppData\Loca...}, goog:chromeOptions: {debuggerAddress: localhost:62750}, javascriptEnabled: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: XP, platformName: XP, proxy: Proxy(direct), setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify}
Session ID: 10b20fa2bc35600b9721907597429a70
*** Element info: {Using=xpath, value=//button[@type='submit' and @title='Log in']}
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
	at java.lang.reflect.Constructor.newInstance(Unknown Source)
	at org.openqa.selenium.remote.http.W3CHttpResponseCodec.createException(W3CHttpResponseCodec.java:187)
	at org.openqa.selenium.remote.http.W3CHttpResponseCodec.decode(W3CHttpResponseCodec.java:122)
	at org.openqa.selenium.remote.http.W3CHttpResponseCodec.decode(W3CHttpResponseCodec.java:49)
	at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:158)
	at org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83)
	at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:552)
	at org.openqa.selenium.remote.RemoteWebDriver.findElement(RemoteWebDriver.java:323)
	at org.openqa.selenium.remote.RemoteWebDriver.findElementByXPath(RemoteWebDriver.java:428)
	at org.openqa.selenium.By$ByXPath.findElement(By.java:353)
	at org.openqa.selenium.remote.RemoteWebDriver.findElement(RemoteWebDriver.java:315)
	at de.derrichter.finance.websync.institute.leaseplanbank.WebAuth.loginWithSelenium(WebAuth.java:116)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at de.derrichter.hibiscus.mashup.crossover.interact.Auth.seleniumLogin(Auth.java:324)
	at de.derrichter.hibiscus.mashup.crossover.websync.institute.leaseplanbank.Collector.run(Collector.java:162)
	at de.derrichter.hibiscus.mashup.crossover.websync.WebSynchronizeJobKontoauszug.execute(WebSynchronizeJobKontoauszug.java:74)
	at de.derrichter.hibiscus.mashup.crossover.websync.WebSynchronizeBackend$WebSyncJobGroup.sync(WebSynchronizeBackend.java:585)
	at de.willuhn.jameica.hbci.synchronize.AbstractSynchronizeBackend$Worker.run(AbstractSynchronizeBackend.java:406)
	at de.willuhn.jameica.gui.GUI$7.run(GUI.java:1060)
Mit welchem Level wird der Datei-Log gewünscht?
Windows 7 Prof. SP1 64-Bit

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1278
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Leaseplan Bank - Fehler beim Setzen des Login-Formulars oder der Felder

Beitrag von Hibiscus-Scripter » Fr 6. Sep 2019, 00:06

So, danke für die Meldung, aber bitte formatiere die Log auch in einem CODE-Block und nicht in einem Zitieren (Quote-) Block, wie in den Posting-Regeln beschrieben.
Das Problem konnte reproduziert und damit untersucht werden.

Gerne mal mit den aktuellen Nightly-Builds von
  • finance.websync
  • hibiscus.mashup
ausprobieren, in welcher die Fehler behoben sein sollten.
:idea: Hilfe hierzu gibst wie immer auch im Tipps und Tricks-Forum


Hier dann bitte auch wieder Rückmeldung geben!
:!: Dabei bitte nicht vergessen:
Sollten dennoch weiterhin Fehler auftreten hier das vollständige Monitor-Log posten!
(formatiert wie in den Posting-Regeln beschrieben)


Gruß

nirbhay
Beiträge: 27
Registriert: Mi 2. Sep 2015, 17:17

Re: Leaseplan Bank - der Kontoauszugssaldo ist aktuell doch es werden noch Buchungen erwartet!

Beitrag von nirbhay » Fr 6. Sep 2019, 12:33

Hallo,

nach dem Update der beiden Nightlies erscheint der Fehler zwar nicht mehr, aber ein weiteres Problem taucht auf. Der letzte Umsatz (eine Zinsgutschrift von 0,67 € vom 01.09.2019) erscheint nicht in der Liste.

Code: Alles auswählen

[06.09.2019 12:29:05] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[06.09.2019 12:29:05]  
[06.09.2019 12:29:05] System-Info: OS[Windows 7 (ver. 6.1) amd64]  Platform[Jameica 2.8.4 | Build: 453 vom 20190211]  Plugin[hibiscus 2.8.13 | Build: 377 vom 20190624]
[06.09.2019 12:29:05] Installierte und aktive PlugIn-Versionen: [Finance.Websync ver. 0.9.5-nightly | Build: 486 vom 20190906] [Hibiscus Mashup ver. 0.9.5-nightly | Build: 352 vom 20190826]
[06.09.2019 12:29:05] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[06.09.2019 12:29:05] OK: Java-Version 1.8.0_221 von 'Oracle Corporation' installiert, aktiv und verwendet Zeichensatz 'Cp1252' (Home: C:\Program Files\Java\jre1.8.0_221)
[06.09.2019 12:29:05] Überprüfe Selenium-Version ...
[06.09.2019 12:29:05] OK: Selenium-Version 3.141.59 installiert und aktiv
[06.09.2019 12:29:05] Überprüfe ChromeDriver-Version ...
[06.09.2019 12:29:05] OK: ChromeDriver-Version 76.0.3809.126 installiert und aktiv
[06.09.2019 12:29:05] Überprüfe PDFBox-Version ...
[06.09.2019 12:29:05] OK: PDFBox-Version 2.0.16 installiert und aktiv
[06.09.2019 12:29:05]  
[06.09.2019 12:29:05] Synchronisiere Konto 'Leaseplan Bank, IBAN NL62LP..077751 [BIC: NL62LPLNXXX]' ...
[06.09.2019 12:29:08] Überprüfe Chromium-Version ...
[06.09.2019 12:29:08] OK. Browser ist: chrome ver. 76
[06.09.2019 12:29:11] Web-Login mit Selenium-WebDriver-Engine mit Anmeldekennung nirb******* auf https://sparen.leaseplanbank.de/ ...
[06.09.2019 12:29:19] LeasePlanBank-Login war erfolgreich
[06.09.2019 12:29:19] Rufe Umsatzübersicht auf und starte Abruf des Kontoauszuges ...
[06.09.2019 12:29:19] Suche Umsätze im Zeitraum vom 23.08.2019 bis 06.09.2019 und lese diese aus ...
[06.09.2019 12:29:23] Wegen Wochende Abrufzeitraum auf 3 Monate gesetzt um ausstehende Transaktionen im akutellen Saldo zu beachten
[06.09.2019 12:29:28] Web-Logout der aktuellen Online-Sitzung ...
[06.09.2019 12:29:30] LeasePlanBank-Logout war erfolgreich
[06.09.2019 12:29:31] Kontoauszug erfolgreich. Importiere Daten ...
[06.09.2019 12:29:31] Ergebnis des Sync: Keine neuen Umsätze vorhanden
[06.09.2019 12:29:31] Saldo aktualisiert von Konto: Leaseplan Bank
[06.09.2019 12:29:31] Info-Warnung: der Kontoauszugssaldo ist aktuell doch es werden noch Buchungen erwartet! Letzter Zwischensaldo ist daher nicht gleich Kontosaldo
[06.09.2019 12:29:31] Das Konto 'Leaseplan Bank, IBAN NL62LP..077751 [BIC: NL62LPLNXXX]' wurde erfolgreich synchronisiert
[06.09.2019 12:29:31] Synchronisierung via non-HBCI (Hibiscus Mashup) erfolgreich beendet
Auch nach einem Rücksetzen des Saldo und Datum und erneutem Abruf werden keine Zinsgutschriften angezeigt. Die letzte abgerufene Zinsgutschrift im Hibiscus war zum 01.08.2019. Ich könnte dem Entwickler das PDF zuschicken.
Windows 7 Prof. SP1 64-Bit

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1278
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Leaseplan Bank - Fehler beim Setzen des Login-Formulars oder der Felder

Beitrag von Hibiscus-Scripter » Sa 7. Sep 2019, 15:39

Hallo,

danke für die Beispiel-PDF, so war es recht angenehm den Fehler zu beheben.
Gerne mal mit der aktuellen Nightly von 'finance.websync' probieren, wie oben beschrieben...

Gruß
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

nirbhay
Beiträge: 27
Registriert: Mi 2. Sep 2015, 17:17

Ihre angegebene Kontonummer ist in der Kontoübersicht nicht vorhanden oder unbekannte Zwischenseite.

Beitrag von nirbhay » Sa 7. Sep 2019, 21:29

Hallo,

leider hat sich nun ein anderer Fehler eingeschlichen:

Code: Alles auswählen

[07.09.2019 21:26:37] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[07.09.2019 21:26:37]  
[07.09.2019 21:26:37] System-Info: OS[Windows 7 (ver. 6.1) amd64]  Platform[Jameica 2.8.4 | Build: 453 vom 20190211]  Plugin[hibiscus 2.8.13 | Build: 377 vom 20190624]
[07.09.2019 21:26:37] Installierte und aktive PlugIn-Versionen: [Finance.Websync ver. 0.9.5-nightly | Build: 489 vom 20190907] [Hibiscus Mashup ver. 0.9.5-nightly | Build: 352 vom 20190826]
[07.09.2019 21:26:37] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[07.09.2019 21:26:37] OK: Java-Version 1.8.0_221 von 'Oracle Corporation' installiert, aktiv und verwendet Zeichensatz 'Cp1252' (Home: C:\Program Files\Java\jre1.8.0_221)
[07.09.2019 21:26:37] Überprüfe Selenium-Version ...
[07.09.2019 21:26:37] OK: Selenium-Version 3.141.59 installiert und aktiv
[07.09.2019 21:26:37] Überprüfe ChromeDriver-Version ...
[07.09.2019 21:26:37] OK: ChromeDriver-Version 76.0.3809.126 installiert und aktiv
[07.09.2019 21:26:37] Überprüfe PDFBox-Version ...
[07.09.2019 21:26:37] OK: PDFBox-Version 2.0.16 installiert und aktiv
[07.09.2019 21:26:37]  
[07.09.2019 21:26:37] Synchronisiere Konto 'Leaseplan Bank, IBAN NL62LP..077751 [BIC: NL62LPLNXXX]' ...
[07.09.2019 21:26:41] Überprüfe Chromium-Version ...
[07.09.2019 21:26:41] OK. Browser ist: chrome ver. 76
[07.09.2019 21:26:44] Web-Login mit Selenium-WebDriver-Engine mit Anmeldekennung nirb******* auf https://sparen.leaseplanbank.de/ ...
[07.09.2019 21:26:55] LeasePlanBank-Login war erfolgreich
[07.09.2019 21:26:55] Rufe Umsatzübersicht auf und starte Abruf des Kontoauszuges ...
[07.09.2019 21:26:55] Suche Umsätze im Zeitraum vom 23.08.2019 bis 07.09.2019 und lese diese aus ...
[07.09.2019 21:26:56] Web-Logout der aktuellen Online-Sitzung ...
[07.09.2019 21:27:14] Warnung: LeasePlanBank-Logout war fehlerhaft; Bitte dem Entwickler im Forum melden!
[07.09.2019 21:27:15] Fehler: Ihre angegebene Kontonummer ist in der Kontoübersicht nicht vorhanden oder unbekannte Zwischenseite. Bitte prüfen
Windows 7 Prof. SP1 64-Bit

nirbhay
Beiträge: 27
Registriert: Mi 2. Sep 2015, 17:17

Re: Leaseplan Bank - Fehler beim Setzen des Login-Formulars oder der Felder

Beitrag von nirbhay » Sa 7. Sep 2019, 21:53

online sieht es aus wie immer.
In der Übersicht erscheint das Tagesgeldkonto mit der vollen IBAN. Die IBAN muss man dann anklicken und gelangt dadurch zur Transaktionsübersicht.
2019-09-07 21_47_12-Übersicht anlegen LeasePlan Bank - LeasePlan Bank.png
Soll ich Dir das Logfile schicken? Mit welchem Trace-Level?
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Windows 7 Prof. SP1 64-Bit

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1278
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Leaseplan Bank - Fehler beim Setzen des Login-Formulars oder der Felder

Beitrag von Hibiscus-Scripter » Sa 7. Sep 2019, 23:22

also ich hab mal da ein richtiges Warten von 30 Sekunden eingebaut, vielleicht dauert es bei dir einfach so lange...
und noch ein Test-Schalter den ich vergessen hatte..

Nochmals mit der Nightly von 'finance.websync'

Gruß
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

nirbhay
Beiträge: 27
Registriert: Mi 2. Sep 2015, 17:17

Re: Leaseplan Bank - Fehler beim Setzen des Login-Formulars oder der Felder

Beitrag von nirbhay » So 8. Sep 2019, 09:54

Danke.

Es läuft wieder. Auch die Zinsgutschrift vom 01.09. ist jetzt drin.
Windows 7 Prof. SP1 64-Bit

Zurück zu „Release 3 - Finance.Websync & Hibiscus Mashup - (Beta 0.x)“