[Erledigt] POI Versionscheck schlägt fehl mit Version 0.9.7

Hier gibt es Support zu den Plugin der neuesten Generation des Hibiscus-Mashup Projekts von Sebastian Richter
KwaiChangCaine
Beiträge: 2
Registriert: Di 30. Apr 2019, 07:43

[Erledigt] POI Versionscheck schlägt fehl mit Version 0.9.7

Beitrag von KwaiChangCaine » Mi 23. Okt 2019, 22:18

Heute Abend habe ich auf die aktuelle Stable Version 0.97 aktualisiert. Bei Abfrage der Barclay-Card kommt jetzt eine Fehlermeldung, dass die POI-Version 4.0.1 statt 4.1.0 ist, obwohl die 4.1.0 installiert ist:

Code: Alles auswählen

[23.10.2019 22:10:22] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[23.10.2019 22:10:22]  
[23.10.2019 22:10:22] System-Info: OS[Mac OS X (ver. 10.15) x86_64]  Platform[Jameica 2.8.4 | Build: 453 vom 20190211]  Plugin[hibiscus 2.8.18 | Build: 382 vom 20190917]
[23.10.2019 22:10:22] Installierte und aktive PlugIn-Versionen: [Finance.Websync ver. 0.9.7 | Build: 525 vom 20191023] [Hibiscus Mashup ver. 0.9.7 | Build: 366 vom 20191023]
[23.10.2019 22:10:22] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[23.10.2019 22:10:22] OK: Java-Version 1.8.0_201 von 'Oracle Corporation' installiert, aktiv und verwendet Zeichensatz 'UTF-8' (Home: /Library/Java/JavaVirtualMachines/jdk1.8.0_201.jdk/Contents/Home/jre)
[23.10.2019 22:10:22] Überprüfe Selenium-Version ...
[23.10.2019 22:10:22] OK: Selenium-Version 3.141.59 installiert und aktiv
[23.10.2019 22:10:22] Überprüfe ChromeDriver-Version ...
[23.10.2019 22:10:22] OK: ChromeDriver-Version 78.0.3904.70 installiert und aktiv
[23.10.2019 22:10:22] Überprüfe POI-Version ...
[23.10.2019 22:10:22] Fehler: Versionschecks fehlerhaft: Fehler: POI-Version zu niedrig. Mindestens Version 4.1.0 wird benötigt. (Ihre Version ist 4.0.1)
Ich habe einmal den Trace-Modus aktiviert, hier der Output:

Code: Alles auswählen

[Wed Oct 23 22:05:46 CEST 2019][TRACE][bg-task:Worker][de.derrichter.hibiscus.mashup.crossover.callback.WebProgressMonitor.log] MonitorLog-Invoke eingegangen - SynchronizeSession: 
[Wed Oct 23 22:05:46 CEST 2019][INFO][bg-task:Worker][de.derrichter.hibiscus.mashup.crossover.callback.WebLogger.info] [WebSync:POIVersionCheck] Überprüfe POI-Version ...
[Wed Oct 23 22:05:46 CEST 2019][DEBUG][bg-task:Worker][de.derrichter.hibiscus.mashup.crossover.callback.WebLogger.debug] [WebSync:POIVersionCheck] minPOIVer: 4.1.0
[Wed Oct 23 22:05:46 CEST 2019][DEBUG][bg-task:Worker][de.derrichter.hibiscus.mashup.crossover.callback.WebLogger.debug] [WebSync:POIVersionCheck] POIVer: 4.0.1
[Wed Oct 23 22:05:46 CEST 2019][DEBUG][bg-task:Worker][de.derrichter.hibiscus.mashup.crossover.callback.WebLogger.debug] [WebSync:POIVersionCheck] minPOIArray[0]: 4 / in parseFloat: 4.0    und    minPOIArray[1]: 1 / in parseFloat: 1.0    und    minPOIArray[2]: 0 / in parseFloat: 0.0
[Wed Oct 23 22:05:46 CEST 2019][DEBUG][bg-task:Worker][de.derrichter.hibiscus.mashup.crossover.callback.WebLogger.debug] [WebSync:POIVersionCheck] POIVerArray[0]: 4 / in parseFloat: 4.0    und    POIVerArray[1]: 0 / in parseFloat: 0.0    und    POIVerArray[1]: 1 / in parseFloat: 1.0
[Wed Oct 23 22:05:46 CEST 2019][ERROR][bg-task:Worker][de.derrichter.hibiscus.mashup.crossover.callback.WebLogger.error] [WebSync:POIVersionCheck] POI-Version zu niedrig. Mindestens Version 4.1.0 wird benötigt. (Ihre Version ist 4.0.1)
[Wed Oct 23 22:05:46 CEST 2019][ERROR][bg-task:Worker][de.derrichter.hibiscus.mashup.crossover.websync.WebSynchronizeBackend$WebSyncJobGroup.sync] Versionschecks fehlerhaft: 
java.lang.Exception: Fehler: POI-Version zu niedrig. Mindestens Version 4.1.0 wird benötigt. (Ihre Version ist 4.0.1)
	at de.derrichter.finance.websync.utils.check.POIVersion.check(POIVersion.java:90)
	at de.derrichter.hibiscus.mashup.crossover.websync.WebSynchronizeBackend$WebSyncJobGroup.sync(WebSynchronizeBackend.java:560)
	at de.willuhn.jameica.hbci.synchronize.AbstractSynchronizeBackend$Worker.run(AbstractSynchronizeBackend.java:406)
	at de.willuhn.jameica.gui.GUI$7.run(GUI.java:1060)

[Wed Oct 23 22:05:46 CEST 2019][ERROR][bg-task:Worker][de.willuhn.jameica.hbci.synchronize.AbstractSynchronizeBackend$Worker.run] error while synchronizing
java.lang.Exception: Versionschecks fehlerhaft: Fehler: POI-Version zu niedrig. Mindestens Version 4.1.0 wird benötigt. (Ihre Version ist 4.0.1)
	at de.derrichter.hibiscus.mashup.crossover.websync.WebSynchronizeBackend$WebSyncJobGroup.sync(WebSynchronizeBackend.java:578)
	at de.willuhn.jameica.hbci.synchronize.AbstractSynchronizeBackend$Worker.run(AbstractSynchronizeBackend.java:406)
	at de.willuhn.jameica.gui.GUI$7.run(GUI.java:1060)

[Wed Oct 23 22:05:46 CEST 2019][INFO][bg-task:Worker][de.willuhn.jameica.hbci.synchronize.AbstractSynchronizeBackend$Worker.updateStatus] updating synchronization status to: ERROR
[Wed Oct 23 22:05:46 CEST 2019][DEBUG][bg-task:Worker][de.willuhn.jameica.messaging.NamedConcurrentQueue.sendMessage] no message consumers found, ignoring message
[Wed Oct 23 22:05:46 CEST 2019][INFO][bg-task:Worker][de.willuhn.jameica.hbci.synchronize.AbstractSynchronizeBackend$Worker.run] stopping synchronization
[Wed Oct 23 22:05:46 CEST 2019][DEBUG][pool-1-thread-1][de.willuhn.jameica.messaging.NamedConcurrentQueue.deliver] deliver message [Wed Oct 23 22:05:46 CEST 2019][ERROR] Fehler: Versionschecks fehlerhaft: Fehler: POI-Version zu niedrig. Mindestens Version 4.1.0 wird benötigt. (Ihre Version ist 4.0.1)
[Wed Oct 23 22:05:46 CEST 2019][INFO][bg-task:Worker][de.willuhn.jameica.hbci.synchronize.AbstractSynchronizeBackend$Worker.run] finished
[Wed Oct 23 22:05:51 CEST 2019][INFO][main][de.willuhn.jameica.gui.internal.parts.BackgroundTaskMonitor$2$1.handleAction] closing background task monitor snapin
[Wed Oct 23 22:05:53 CEST 2019][DEBUG][main][de.willuhn.jameica.gui.parts.table.FeatureClipboard.applyShortcut] bound de.willuhn.jameica.gui.parts.table.FeatureClipboard$2@77648321
Mit den vorherigen Nightly-Versionen hat das noch geklappt. Alle Plugins sind auf der aktuellen Stable-Version:
Bildschirmfoto 2019-10-23 um 22.16.03.png
Ich habe noch einmal komplett auf alle nightly-Versionen aktualisiert und der Fehler bleibt.
Was kann ich noch prüfen?
Viele Grüße, Frank
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1614
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: POI Versionscheck schlägt fehl mit Version 0.9.7

Beitrag von Hibiscus-Scripter » Do 24. Okt 2019, 08:17

so hab mir jetzt nochmals das Paket angeschaut und gesehen, dass sich da wieder Apache Tika mit eingeschlichen hat (vermutlich mit meinen ganzen Synchronisationsfehlern in letzter Zeit), dadurch war POI zweimal integriert (da auch in Tika) und das Paket war ja auch über 80MB groß.

Also von daher bitte einfach nochmals das Plugin Apache POI drüber installieren:
Menü Mashup --> non-HBCI Plugins online suchen...


kann den Fehler bei mir gerade nicht reproduzieren?!
Mir ist absolut schleierhaft warum der bei dir da eine andere Version zurück geben sollte ...
Sehe im dem Log sonst nur einen Beschriftungsfehler, aber die Version kommt ja scheinbar wirklich so, nur warum ...

Du könntest mal über die Kommandozeile bei der .jar-Datei von POI nach der Version fragen ... nichts anderes macht das Plugin.
Einfach ein Terminal-Fenster öffnen und das rein kopieren und auslösen:

Code: Alles auswählen

java -cp jameica\plugins\hibiscus.scripting.poi\lib\poi-4.1.0.jar org.apache.poi.Version

Andernsfalls, was hast du noch für Plugins installiert?
Eventuell oder vermutlich gibt es da eines, dass auch Apache POI verwendet, aber eben in einer älteren Version?
Daher vielleicht einfach mal im Plugins-Ordner nach "poi" suchen ...


Gruß
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten (Der Post wird ansonsten gelöscht)

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum (Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website)

Wer ein Dankeschön für die Arbeit und Unkosten senden möchte, kann gerne auch :arrow: Spenden

KwaiChangCaine
Beiträge: 2
Registriert: Di 30. Apr 2019, 07:43

Re: POI Versionscheck schlägt fehl mit Version 0.9.7

Beitrag von KwaiChangCaine » Do 24. Okt 2019, 22:35

Es funktioniert bei mir jetzt auch mit der neuen Version.
Herzlichen Dank für die schnelle Hilfe!

Zurück zu „Hibiscus Mashup über Finance.Websync - (Beta 0.x = neue Release 3 der alten Scripte)“