[Geschlossen] Fehler: SeleniumWebDriverInit fehlerhaft: unknown error: DevToolsActivePort

Hier gibt es Support zu den Plugin der neuesten Generation des Hibiscus-Mashup Projekts von Sebastian Richter
Otti
Beiträge: 12
Registriert: Fr 3. Nov 2017, 23:45

[Geschlossen] Fehler: SeleniumWebDriverInit fehlerhaft: unknown error: DevToolsActivePort

Beitrag von Otti » Di 3. Dez 2019, 11:30

Hallo,

ich benutze Hibsicus inklusive einiger Scripte seit Ewigkeiten.
Seit Ende Oktober bekomme ich die Kreditkartendaten der DKB nicht mehr übermittelt.
Ich bin zu der Zeit irgendwann von Ubuntu 19.04 auf 19.10 umgestiegen.

Ich dachte erst, dass sich das Problem wieder gibt und durch die ganzen
Umstellungen bei der PSD Richtlinie entstanden ist.

Das Forum hat mir leider nicht geholfen das Problem zu erkennen und zu
beseitigen.

Über eine hilfreiche Antwort würde ich mich freuen!

Das Log sagt folgendes:

Code: Alles auswählen

[03.12.2019 11:18:34] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[03.12.2019 11:18:34]  
[03.12.2019 11:18:34] System-Info: OS[Linux (ver. 5.3.0-24-generic) amd64]  Platform[Jameica 2.8.4 | Build: 453 vom 20190211]  Plugin[hibiscus 2.8.21 | Build: 385 vom 20191102]
[03.12.2019 11:18:34] Installierte und aktive PlugIn-Versionen: [Finance.Websync ver. 0.9.7 | Build: 530 vom 20191024] [Hibiscus Mashup ver. 0.9.7 | Build: 366 vom 20191023]
[03.12.2019 11:18:34] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[03.12.2019 11:18:34] OK: Java-Version 1.8.0_221 von 'Oracle Corporation' installiert, aktiv und verwendet Zeichensatz 'UTF-8' (Home: /opt/jameica/javaruntime)
[03.12.2019 11:18:34] Überprüfe Selenium-Version ...
[03.12.2019 11:18:34] OK: Selenium-Version 3.141.59 installiert und aktiv
[03.12.2019 11:18:34] Überprüfe ChromeDriver-Version ...
[03.12.2019 11:18:34] OK: ChromeDriver-Version 78.0.3904.70 installiert und aktiv
[03.12.2019 11:18:34]  
[03.12.2019 11:18:34] Synchronisiere Konto 'DKB - Visa , IBAN DE6312..xxxxxx [Deutsche Kr...ank Berlin]' ...
[03.12.2019 11:19:34] Fehler: SeleniumWebDriverInit fehlerhaft: Erstellen des WebClient fehlgeschlagen!
Stacktrace: java.lang.Exception: org.openqa.selenium.WebDriverException: unknown error: DevToolsActivePort file doesn't exist
Build info: version: '3.141.59', revision: 'e82be7d358', time: '2018-11-14T08:25:48'
System info: host: 'Ryzen', ip: '127.0.1.1', os.name: 'Linux', os.arch: 'amd64', os.version: '5.3.0-24-generic', java.version: '1.8.0_221'
Driver info: driver.version: ChromeDriver
remote stacktrace: #0 0x5591cb6397e9 <unknown>

	at de.derrichter.finance.websync.connector.ChromeDriverWebClientInit.connConfig(ChromeDriverWebClientInit.java:703)
	at de.derrichter.hibiscus.mashup.crossover.websync.institute.dkbvisa.Collector.run(Collector.java:149)
	at de.derrichter.hibiscus.mashup.crossover.websync.WebSynchronizeJobKontoauszug.execute(WebSynchronizeJobKontoauszug.java:74)
	at de.derrichter.hibiscus.mashup.crossover.websync.WebSynchronizeBackend$WebSyncJobGroup.sync(WebSynchronizeBackend.java:618)
	at de.willuhn.jameica.hbci.synchronize.AbstractSynchronizeBackend$Worker.run(AbstractSynchronizeBackend.java:406)
	at de.willuhn.jameica.gui.GUI$7.run(GUI.java:1060)
Caused by: org.openqa.selenium.WebDriverException: unknown error: DevToolsActivePort file doesn't exist
Build info: version: '3.141.59', revision: 'e82be7d358', time: '2018-11-14T08:25:48'
System info: host: 'Ryzen', ip: '127.0.1.1', os.name: 'Linux', os.arch: 'amd64', os.version: '5.3.0-24-generic', java.version: '1.8.0_221'
Driver info: driver.version: ChromeDriver
remote stacktrace: #0 0x5591cb6397e9 <unknown>

	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
	at org.openqa.selenium.remote.W3CHandshakeResponse.lambda$errorHandler$0(W3CHandshakeResponse.java:62)
	at org.openqa.selenium.remote.HandshakeResponse.lambda$getResponseFunction$0(HandshakeResponse.java:30)
	at org.openqa.selenium.remote.ProtocolHandshake.lambda$createSession$0(ProtocolHandshake.java:126)
	at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:193)
	at java.util.Spliterators$ArraySpliterator.tryAdvance(Spliterators.java:958)
	at java.util.stream.ReferencePipeline.forEachWithCancel(ReferencePipeline.java:126)
	at java.util.stream.AbstractPipeline.copyIntoWithCancel(AbstractPipeline.java:499)
	at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:486)
	at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:472)
	at java.util.stream.FindOps$FindOp.evaluateSequential(FindOps.java:152)
	at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
	at java.util.stream.ReferencePipeline.findFirst(ReferencePipeline.java:464)
	at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:128)
	at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:74)
	at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:136)
	at org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83)
	at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:552)
	at org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:213)
	at org.openqa.selenium.remote.RemoteWebDriver.<init>(RemoteWebDriver.java:131)
	at org.openqa.selenium.chrome.ChromeDriver.<init>(ChromeDriver.java:181)
	at org.openqa.selenium.chrome.ChromeDriver.<init>(ChromeDriver.java:168)
	at org.openqa.selenium.chrome.ChromeDriver.<init>(ChromeDriver.java:157)
	at de.derrichter.finance.websync.connector.ChromeDriverWebClientInit.connConfig(ChromeDriverWebClientInit.java:552)
	... 5 more

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1382
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Fehler: SeleniumWebDriverInit fehlerhaft: unknown error: DevToolsActivePort

Beitrag von Hibiscus-Scripter » Di 3. Dez 2019, 11:40

Dies sieht schwer danach aus, dass dein Chrome-Browser sehr alt ist, dieser muss also neu installiert werden.
Oder deinstalliert werden, dann holt das Plugin den selbst.

Hierzu auch ein bereits existierendes Thema, das du nicht gefunden hast:
viewtopic.php?f=34&t=752

Gruß
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

Otti
Beiträge: 12
Registriert: Fr 3. Nov 2017, 23:45

Re: Fehler: SeleniumWebDriverInit fehlerhaft: unknown error: DevToolsActivePort

Beitrag von Otti » Di 3. Dez 2019, 12:06

Es gibt Chromium nur noch als Snap seit 19.10 , deswegen hatte ich manuell einen anderen Treiber geladen, das wurde mir als Bastellösung vorgeworfen und ich habe es wieder rückgängig gemacht.
Auf die Snap Librarys kann anscheinend nicht zugegriffen werden!? Mein Chromium ist aktuell.

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1382
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Fehler: SeleniumWebDriverInit fehlerhaft: unknown error: DevToolsActivePort

Beitrag von Hibiscus-Scripter » Di 3. Dez 2019, 12:10

von Chromium gibt es halt nur Snaps oder Nightly-Builds und da die richtige zu finden ist umständlicher.
Von daher wieso installierst du nicht einfach wie vorgeschlagen die aktuell stabile Version von Chrome oder halt ganz deinstallieren, wie auch vorgeschlagen?

Dein Problem kannst nur du selbst an deinem PC lösen, wenn du es anders machen willst als gedacht und empfohlen kann ich dafür natürlich keinen Support geben.

Gruß
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

Otti
Beiträge: 12
Registriert: Fr 3. Nov 2017, 23:45

Re: Fehler: SeleniumWebDriverInit fehlerhaft: unknown error: DevToolsActivePort

Beitrag von Otti » Di 3. Dez 2019, 12:14

mein Paketmanager gibt das nicht her
Bildschirmfoto vom 2019-12-03 12-11-09.png
Demnach bin ich aktuell. Weil aber in den Plugins angeboten wird, diese auf der Webseite des Anbieters manuell nachzuladen hatte ich das getan, was keine Besserung brachte. Ich bin leider nur Endanwender und kein Programmierer ich mache mir das Leben ja nicht absichtlich schwer.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1382
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Fehler: SeleniumWebDriverInit fehlerhaft: unknown error: DevToolsActivePort

Beitrag von Hibiscus-Scripter » Di 3. Dez 2019, 12:22

ich weiß zwar nicht was ich mit dem Screenshot anfangen soll aber naja, ich würde mal nach "chrome" suchen und nicht nach "chromium".

Ansonsten, ein allerletztes Mal:
Ich programmiere das hier in meiner Freizeit und ich werde bestimmt nicht anfangen Leuten hier Lösungen für Ihre privaten PC-Probleme zu liefern, ich bin kein First-Level-Support für Privatanwender.
Dazu gibt es Bekannte, Verwandte und Google, usw.
Ich kann nichts für dein Betriebssystem oder deinem Rechner allgemein.
Aber wenn man bei Google mal "Chrome Linux" eingibt kommt man hier her:
https://support.google.com/chrome/answe ... ktop&hl=de

Von daher muss ich das Thema hier jetzt schließen, den das du den einfach deinstallieren kannst überliest du ja auch die Ganze Zeit ganz fleißig und dafür hab ich auch keine Nerven.

Gruß

EDIT: Entschuldigung hatte wohl wieder die Zwinker-Smilys vergessen, weswegen sich Leute immer angegriffen fühlen wenn man Ihnen alles dreimal sagen muss, also ;) :oops: 8-) :roll: :ugeek:
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

Zurück zu „Hibiscus Mashup über Finance.Websync - (Beta 0.x = neue Release 3 der alten Scripte)“