[Geschlossen] Chrome/Chromium nicht in kompatibler Version zu ChromeDriver

Hier gibt es Support zu den Plugin der neuesten Generation des Hibiscus-Mashup Projekts von Sebastian Richter
DerDominik
Beiträge: 4
Registriert: Sa 30. Mär 2019, 15:23

[Geschlossen] Chrome/Chromium nicht in kompatibler Version zu ChromeDriver

Beitrag von DerDominik » So 1. Mär 2020, 10:36

Hallo zusammen,

habe seit kurzem das Problem, dass ich z.B. bei DKB Visa oder auch Rabodirect folgende Fehlermeldungen beim Abrufen der Konten erhalte:

Code: Alles auswählen

[01.03.2020 10:34:16] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[01.03.2020 10:34:16]  
[01.03.2020 10:34:16] System-Info: OS[Windows 10 (ver. 10.0) amd64]  Platform[Jameica 2.8.6 | Build: 455 vom 20191101]  Plugin[hibiscus 2.8.23 | Build: 387 vom 20200114]
[01.03.2020 10:34:16] Installierte und aktive Plugin-Versionen: [Finance.Websync ver. 0.9.10-nightly | Build: 565 vom 20200225] [Hibiscus Mashup ver. 0.9.10 | Build: 372 vom 20200224]
[01.03.2020 10:34:16] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[01.03.2020 10:34:16] OK: Java-Version 11.0.6 von 'AdoptOpenJDK' installiert, aktiv und verwendet Zeichensatz 'Cp1252' (Home: C:\Program Files\AdoptOpenJDK\jdk-11.0.6.10-hotspot)
[01.03.2020 10:34:16] Überprüfe Selenium-Version ...
[01.03.2020 10:34:16] OK: Selenium-Version 3.141.59 installiert und aktiv
[01.03.2020 10:34:16] Überprüfe ChromeDriver-Version ...
[01.03.2020 10:34:17] OK: ChromeDriver-Version 81.0.4044.20 installiert und aktiv
[01.03.2020 10:34:17]  
[01.03.2020 10:34:17] Synchronisiere Konto 'Kreditkarte - DKB, IBAN DExxxx.xxxx [Deutsche Kr...ank Berlin]' ...
[01.03.2020 10:34:17] Selenium WebDriver über ChromeDriver wird gestartet ...
[01.03.2020 10:34:18] -> Erst-Initialisierung des WebDriver nicht erfolgreich, der Start dauert daher länger:
[01.03.2020 10:34:18] Hinweis: Chrome/Chromium liegt in einer nicht kompatiblen Version vor (Fehler: session not created: This version of ChromeDriver only supports Chrome version 81) ...
[01.03.2020 10:34:18] ... daher wird nun der automatisch nachgeladene Chromium verwendet ... (dieser wird wieder entfernt wenn Chrome in einer kompatiblen Version gefunden wird!)
[01.03.2020 10:34:19] Fehler: SeleniumWebDriverInit fehlerhaft: Pfad zur Chromium-Binary scheint nicht korrekt. (Existiert nicht) Bitte überprüfen Sie diesen: C:\ProgramData\Chrome-Headless\chrome-win32\chrome.exe
Wegen dem Programmpfad habe ich nachgeschaut, dieser existiert. Allerdings sind keine Dateien enthalten.

Hat jemand eine Idee, wo die Ursache des Problems liegt und was ich machen kann?


Danke vorab und noch einen schönen Sonntag :-)

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1396
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: DKB-Visa Chrome/Chromium nicht in kompatibler Version

Beitrag von Hibiscus-Scripter » So 1. Mär 2020, 13:32

So, danke erst einmal für die ordentliche Meldung mit der vollständigen Monitor-Log,
Die Lösung hierzu, also was du falsch gemacht hast, wurde dir allerdings bereits im Homebanking-Forum beantwortet?!

Also hier nochmals:
Du benutzt z. B. die Testing-Version (81.x - also die Beta) von ChromeDriver?! Hier MUSST du die aktuelle Stable-Version (80.x) verwenden!

Nochmals für Alle:
  • Installiert Nightly- oder Testing-Versionen nur wenn Ihr direkt dazu aufgefordert wurdet! Ansonsten wird es wie hier auch zu Fehlern kommen oder es gar nicht gehen!
  • Solltet Ihr unter den Einstellungen von Jameica (Datei->Einstellungen->Plugins->Button "Repositories bearbeiten) mein Testing-Repository angegeben haben und zugleich die Automatischen-Updates aktiviert sein, wird dies NICHT empfohlen, da genau solche fehlerhaften Installationen entstehen können.
    Alle sollten das Testing-Repository aus den Einstellungen entfernen und auf dieses nur manuell zugreifen, wie unter im Tipps und Tricks beschrieben.
Gruß

PS: vollständige Jameica-Logs sind, auch wie in den Posting-Regeln beschrieben, nur nach Aufforderung und auch dann nur per Mail oder Privater Nachricht zu versenden!
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten
Grobe Verstöße gegen Posting-Regeln oder Doppel-Posts werden gelöscht!

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum
Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website

DerDominik
Beiträge: 4
Registriert: Sa 30. Mär 2019, 15:23

Re: DKB-Visa Chrome/Chromium nicht in kompatibler Version

Beitrag von DerDominik » So 1. Mär 2020, 14:52

Super, vielen Dank für die rasche Antwort :-)
Hab die stable Versionen installiert und ab da ging es dann auch sofort :-)

Vielen Dank nochmals und einen schönen Sonntag :-)

Zurück zu „Hibiscus Mashup über Finance.Websync - (Beta 0.x = neue Release 3 der alten Scripte)“