[Gelöst durch manuelles Update] ChromeDriverVersion angeblich zu niedrig

Hier gibt es Support zu den Plugin der neuesten Generation des Hibiscus-Mashup Projekts von Sebastian Richter
moncada
Beiträge: 11
Registriert: Sa 15. Jun 2019, 07:32

[Gelöst durch manuelles Update] ChromeDriverVersion angeblich zu niedrig

Beitrag von moncada » Fr 10. Apr 2020, 16:37

Hallo,
ich habe alle updates in Jameica durchgeführt (den Chromedriver sogar mehrmals)
Googlw-Chrome Version 81.0.4044.92 (Offizieller Build) (64-Bit)
In meiner Signatur sind die Versionshinweise aktuell gepflegt (siehe Anhang)
Browser-Version.jpg
Hier der Log-Auszug

Code: Alles auswählen

[10.04.2020 16:26:23] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[10.04.2020 16:26:23]  
[10.04.2020 16:26:23] System-Info: OS[Windows 10 (ver. 10.0) amd64]  Platform[Jameica 2.8.6 | Build: 455 vom 20191101]  Plugin[hibiscus 2.8.23 | Build: 387 vom 20200114]
[10.04.2020 16:26:23] Installierte und aktive Plugin-Versionen: [Finance.Websync ver. 0.9.11 | Build: 585 vom 20200409] [Hibiscus Mashup ver. 0.9.11 | Build: 380 vom 20200409]
[10.04.2020 16:26:23] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[10.04.2020 16:26:23] OK: Java-Version 11.0.5 von 'AdoptOpenJDK' installiert, aktiv und verwendet Zeichensatz 'Cp1252' (Home: C:\Program Files\jameica\jre-win64)
[10.04.2020 16:26:23] Überprüfe Selenium-Version ...
[10.04.2020 16:26:23] OK: Selenium-Version 3.141.59 installiert und aktiv
[10.04.2020 16:26:23] Überprüfe ChromeDriver-Version ...
[10.04.2020 16:26:24] Fehler: Versionschecks fehlerhaft ChromeDriver-Version zu niedrig. Mindestens Version 80.0 wird benötigt. (Ihre Version ist 79.0.3945.36)
Danke und Gruß
moncada
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
  • Jameica: 2.8.6, SWT-Version: 4919/win32, Java-Version: 11.0.5, Windows 10 amd64, Build:455 [Datum 20191101]
  • Hibiscus: 2.8.24, HBCIJava-Version: 3.1.42 Datenbank-Version: 67, Build: 388 [Datum 20200708]
  • Mashup: 0.9.12, Datenbank-Version 1, Build: 387 [Datum 20200602]
  • Contract-Manager: 0.5.5
  • JaDepot: 1.5.0-nightly, Build: 108 [Datum 20190627], Datenbank-Version: 5

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1614
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: ChromeDriverVersion angeblich zu niedrig

Beitrag von Hibiscus-Scripter » Fr 10. Apr 2020, 17:36

Du sprichst hier von ChromeDriver, hast aber ein Screenshot von Google Chrome gepostet. Was denn nun?
Dies sind zwei völlig verschiedene Dinge.
  • Der ChromeDriver ist ein WebDriver der mit Hilfe von Selenium einen Web-Browser steuern kann
  • Goolge Chrome oder die Open-Source Version Chromium sind dieser Web-Browser
Von daher denke ich du hast nicht mehrmals den ChromeDriver upgedatet. Ich habe den bei extra nochmals gelöscht um den Update-Download zu prüfen und es wird ganz sauber die aktuelle Version installiert:
ChromeDriver-Version 81.0.4044.69 installiert und aktiv
In deiner Log sieht man, dass du ein alte Version installiert hast:
ChromeDriver-Version zu niedrig. Mindestens Version 80.0 wird benötigt. (Ihre Version ist 79.0.3945.36)
Du musst ein Update des ChromeDriver-Plugins durchführen:
Wie das geht steht z. B. in der FAQ :arrow: Fehlermeldungen, dass eine Plugin-Version zu niedrig sei oder ein Plugin nicht installiert ist

Tipp: Aktiviere einfach in den Einstellungen von Jameica die automatischen Updates und stelle diese auf einen Tag ein.
Manuell kann man ganz schnell und einfach über das Hauptmenü "Mashup->non-HBCI Plugins online suchen..."

Gruß :wave:
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten (Der Post wird ansonsten gelöscht)

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum (Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website)

Wer ein Dankeschön für die Arbeit und Unkosten senden möchte, kann gerne auch :arrow: Spenden

moncada
Beiträge: 11
Registriert: Sa 15. Jun 2019, 07:32

Re: ChromeDriverVersion angeblich zu niedrig

Beitrag von moncada » Fr 10. Apr 2020, 18:06

Hi,
sorry für die Verwirrung, der Screenshot sollte nur nachweisen, dass ich den aktuellen Google Chrome installiert habe.

Hier nun ein Screenshot der zeigt ich habe den aktuellen ChromeDriver installiert und trotzdem kommt der Hinweis.
ChromeDriver-2.jpg
Danke und Gruß
moncada
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
  • Jameica: 2.8.6, SWT-Version: 4919/win32, Java-Version: 11.0.5, Windows 10 amd64, Build:455 [Datum 20191101]
  • Hibiscus: 2.8.24, HBCIJava-Version: 3.1.42 Datenbank-Version: 67, Build: 388 [Datum 20200708]
  • Mashup: 0.9.12, Datenbank-Version 1, Build: 387 [Datum 20200602]
  • Contract-Manager: 0.5.5
  • JaDepot: 1.5.0-nightly, Build: 108 [Datum 20190627], Datenbank-Version: 5

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1614
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: ChromeDriverVersion angeblich zu niedrig

Beitrag von Hibiscus-Scripter » Fr 10. Apr 2020, 18:10

da kann ich jetzt auch nicht direkt sagen was auf deinem System da nicht stimmt.
Habe jetzt extra nochmals bei mir die veraltete Version 79.x installiert. Dann habe ich natürlich die selbe Fehlermeldung erhalten. Dann habe ich ganz normal über das Menü das Update drüber installiert und fertig, es geht.

Hast du den ChromeDriver mal in das Programm-Verzeichnis statt in das Benutzer-Verzeichnis installiert?
(Das Programm-Verzeichnis wird niemals empfohlen da hier gerne Berechtigungsprobleme auftreten!)
Wo der Standard-Benutzerorder ist kannst du hier nachlesen ...

Was passiert denn wenn du mal Jameica schließt und unter deinem "<Benutzerordner>/plugins" den Ordner "hibiscus.scripting.chromedriver" vollständig löscht und dann Jameica wieder startest?

Und was passiert wenn du dann danach nochmals den ChromeDriver neu installierst? Also nach dem manuellen löschen des Plugin-Ordners!

Gruß :wave:
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten (Der Post wird ansonsten gelöscht)

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum (Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website)

Wer ein Dankeschön für die Arbeit und Unkosten senden möchte, kann gerne auch :arrow: Spenden

moncada
Beiträge: 11
Registriert: Sa 15. Jun 2019, 07:32

Re: ChromeDriverVersion angeblich zu niedrig

Beitrag von moncada » Sa 11. Apr 2020, 08:58

Hallo,

es funktioniert wieder, ich habe das Script unter Benutzer und Programme gelsöcht und neu installiert und es funktionierte.

Unter Benutzer gab es Unterhalt des ChromeDriver-Ordner noch ein Ordner bin (nachdem ich in Jameica das Script entfernt hatte), vermutlich hat sich das Tool "verschluckt" und nicht alle alte Daten beim updaten gelöscht. Ich habe den ChromeDriver-Ordner manuell gelöscht und dann über mashup "non HBCI-Plugin manuell suchen) neu installiert (wieder unter Benutzer) und es funktionierte.

Danke für die Hilfe

Gruß
moncada
  • Jameica: 2.8.6, SWT-Version: 4919/win32, Java-Version: 11.0.5, Windows 10 amd64, Build:455 [Datum 20191101]
  • Hibiscus: 2.8.24, HBCIJava-Version: 3.1.42 Datenbank-Version: 67, Build: 388 [Datum 20200708]
  • Mashup: 0.9.12, Datenbank-Version 1, Build: 387 [Datum 20200602]
  • Contract-Manager: 0.5.5
  • JaDepot: 1.5.0-nightly, Build: 108 [Datum 20190627], Datenbank-Version: 5

Zurück zu „Hibiscus Mashup über Finance.Websync - (Beta 0.x = neue Release 3 der alten Scripte)“