Umsatzabruf Volkswagenbank funktioniert nicht mehr

Hier gibt es Support zu den Plugin der neuesten Generation des Hibiscus-Mashup Projekts von Sebastian Richter
jottka
Beiträge: 12
Registriert: Mi 14. Mär 2018, 11:23

Umsatzabruf Volkswagenbank funktioniert nicht mehr

Beitrag von jottka » Do 30. Apr 2020, 14:04

Hallo,
seit einiger Zeit funktioniert der Umsatzabruf bei der Volkswagenbank bei mir nicht mehr. Es gab Probleme mit der Chromdriver-Version. Ich habe daraufhin die Tipps und Hinweise, welche ich hier im Forum zu diesem Problem gefunden habe, befolgt (chromedriver unter plugins im Homeverzeichnis gelöscht und dann neu installiert). Leider hat das nicht den gewünschten Erfolg gebracht. Dann habe ich mit dem Sorglos-Paket ein Jameica-Update gemacht und, da es noch immer nicht funktionierte, habe ich noch die nightly-builds von hibiscus.mashup und finance.websync installiert. Auch das hat das Problem nicht vollständig gelöst. Ich bin zwar weiter gekommen bis zum Login und Photo-Tan PIN-Eingabe aber nach dem Web-Logout der aktuellen Online-Sitzung kommt wieder die Meldung der fehlerhaften Synchronisation:

Code: Alles auswählen

30.04.2020 12:16:09] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[30.04.2020 12:16:09]  
[30.04.2020 12:16:09] System-Info: OS[Linux (ver. 4.15.0-99-generic) amd64]  Platform[Jameica 2.8.6 | Build: 455 vom 20191101]  Plugin[hibiscus 2.8.23 | Build: 387 vom 20200114]
[30.04.2020 12:16:09] Installierte und aktive Plugin-Versionen: [Finance.Websync ver. 0.9.11-nightly | Build: 596 vom 20200427] [Hibiscus Mashup ver. 0.9.11-nightly | Build: 385 vom 20200426]
[30.04.2020 12:16:09] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[30.04.2020 12:16:09] OK: Java-Version 1.8.0_241 von 'Oracle Corporation' installiert, aktiv und verwendet Zeichensatz 'UTF-8' (Home: /opt/jameica/javaruntime)
[30.04.2020 12:16:09] Überprüfe Selenium-Version ...
[30.04.2020 12:16:09] OK: Selenium-Version 3.141.59 installiert und aktiv
[30.04.2020 12:16:09] Überprüfe ChromeDriver-Version ...
[30.04.2020 12:16:10] OK: ChromeDriver-Version 81.0.4044.69 installiert und aktiv
[30.04.2020 12:16:10]  
[30.04.2020 12:16:10] Synchronisiere Konto 'Volkswagenbank - Giro, Kto. 15******** [Volkswagen Bank]' ...
[30.04.2020 12:16:10] Selenium WebDriver über ChromeDriver wird gestartet ...
[30.04.2020 12:16:13] -> Erst-Initialisierung des WebDriver nicht erfolgreich, der Start dauert daher länger:
[30.04.2020 12:16:13] Hinweis: Chrome/Chromium liegt in einer nicht kompatiblen Version vor (Fehler: session not created: This version of ChromeDriver only supports Chrome version 81) ...
[30.04.2020 12:16:13] ... dieser wird daher nun automatisch nachgeladen ... (und wird wieder entfernt, wenn Chrome in einer kompatiblen Version gefunden wird!)
[30.04.2020 12:16:15] Download-Fortschritt: 10%
[30.04.2020 12:16:17] Download-Fortschritt: 20%
[30.04.2020 12:16:20] Download-Fortschritt: 30%
[30.04.2020 12:16:22] Download-Fortschritt: 40%
[30.04.2020 12:16:24] Download-Fortschritt: 50%
[30.04.2020 12:16:26] Download-Fortschritt: 60%
[30.04.2020 12:16:28] Download-Fortschritt: 70%
[30.04.2020 12:16:31] Download-Fortschritt: 80%
[30.04.2020 12:16:33] Download-Fortschritt: 90%
[30.04.2020 12:16:35] Download-Fortschritt: 100%
[30.04.2020 12:16:35] ... Download erfolgreich, beginne entpacken ...
[30.04.2020 12:16:46] OK. Chrome/Chromium erfolgreich bezogen und abgelegt unter '/home/jkanis/.chrome-headless'
[30.04.2020 12:16:46] Sicherheits-Check der Integrität des alternativen Chromium-Browser gegen Manipulation ...
[30.04.2020 12:16:54] OK. Ergebnis der Berechnung: 5129640F3220184C8ECD4EAA49259A92 (Dauer: 7 Sek.)
[30.04.2020 12:16:56] Web-Login mit Selenium-WebDriver-Engine mit Anmeldekennung *********** auf https://banking.vwfs.de/PBODE-FE-UI/#/login ...
[30.04.2020 12:17:33] VWBank-Login war erfolgreich
[30.04.2020 12:17:33] Rufe Umsatzübersicht auf und starte Abruf des Kontoauszuges ...
[30.04.2020 12:17:33] Suche Umsätze im Zeitraum vom 25.03.2020 bis 30.04.2020 und lese diese aus ...
[30.04.2020 12:18:08] Web-Logout der aktuellen Online-Sitzung ...
[30.04.2020 12:18:12] VWBank-Logout war erfolgreich
[30.04.2020 12:18:17] Fehler: Angegebene Kontonummer oder Kontodetails-Link nicht gefunden, prüfen Sie Ihre Angaben oder melden Sie den Fehler im Forum
[30.04.2020 12:18:17] Synchronisierung via non-HBCI (Hibiscus Mashup) wird nach Fehler fortgesetzt
[30.04.2020 12:18:17]  
[30.04.2020 12:18:17] Synchronisiere Konto 'Volkswagenbank - Visa-Card, IBAN DE15********* [Volkswagen Bank]' ...
[30.04.2020 12:18:17] Selenium WebDriver über ChromeDriver wird gestartet ...
[30.04.2020 12:18:18] -> Erst-Initialisierung des WebDriver nicht erfolgreich, der Start dauert daher länger:
[30.04.2020 12:18:18] Hinweis: Chrome/Chromium liegt in einer nicht kompatiblen Version vor (Fehler: session not created: This version of ChromeDriver only supports Chrome version 81) ...
[30.04.2020 12:18:18] ... daher wird nun der automatisch nachgeladene Chromium verwendet ... (dieser wird wieder entfernt wenn Chrome in einer kompatiblen Version gefunden wird!)
[30.04.2020 12:18:18] Sicherheits-Check der Integrität des alternativen Chromium-Browser gegen Manipulation ...
[30.04.2020 12:18:25] OK. Ergebnis der Berechnung: 5129640F3220184C8ECD4EAA49259A92 (Dauer: 7 Sek.)
[30.04.2020 12:18:26] Überprüfe Chromium-Version ...
[30.04.2020 12:18:26] OK. Browser ist: chrome ver. 81
[30.04.2020 12:18:27] Web-Login mit Selenium-WebDriver-Engine mit Anmeldekennung *********** auf https://banking.vwfs.de/PBODE-FE-UI/#/login ...
[30.04.2020 12:18:59] VWBank-Login war erfolgreich
[30.04.2020 12:18:59] Rufe Umsatzübersicht auf und starte Abruf des Kontoauszuges ...
[30.04.2020 12:19:00] Suche Umsätze im Zeitraum vom 25.03.2020 bis 30.04.2020 und lese diese aus ...
[30.04.2020 12:19:34] Web-Logout der aktuellen Online-Sitzung ...
[30.04.2020 12:19:38] VWBank-Logout war erfolgreich
[30.04.2020 12:19:38] Fehler: Angegebene Kontonummer oder Kontodetails-Link nicht gefunden, prüfen Sie Ihre Angaben oder melden Sie den Fehler im Forum
Ich bin nun etwas ratlos, weiß nicht, was ich noch tun kann und hoffe auf eine Lösung.

Gruß Jürgen

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1472
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Umsatzabruf Volkswagenbank funktioniert nicht mehr

Beitrag von Hibiscus-Scripter » Do 30. Apr 2020, 16:56

Bei beiden Konten steht ja als eindeutiger Fehler:
Angegebene Kontonummer oder Kontodetails-Link nicht gefunden, prüfen Sie Ihre Angaben oder melden Sie den Fehler im Forum
Also sind die Daten so angegeben wie Sie im Onlinebanking sichtbar sind?
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten (Der Post wird ansonsten gelöscht)

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum (Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website)

Wer ein Dankeschön für die Arbeit und Unkosten senden möchte, kann gerne auch :arrow: Spenden

jottka
Beiträge: 12
Registriert: Mi 14. Mär 2018, 11:23

Re: Umsatzabruf Volkswagenbank funktioniert nicht mehr

Beitrag von jottka » Do 30. Apr 2020, 17:33

Hallo Hibiscus-Scripter,
danke für die schnelle Reaktion. Ich habe gerade noch einmal die Zugangsdaten kontrolliert, bei einem Konto hat die IBAN gefehlt, nur Konto-Nr. und Bankleitzahl war eingetragen. Ich habe daran aber seit Jahren nichts geändert. Als Zugangsweg ist non-HBCI (Hibiscus Mashup) eingetragen. Was ich jetzt noch neu eingestellt habe, ist: PIN/TAN Web (non-HBCI). Das war bei allen Konten nicht eingestellt. Ist das neu? Jetzt hat es jedenfalls wieder funktioniert, vermutlich war es das.
Nochmals vielen Dank und einen schönen 1. Mai!
Bleib gesund!
Jürgen

Benutzeravatar
Hibiscus-Scripter
Administrator
Administrator
Beiträge: 1472
Registriert: Mi 30. Okt 2013, 17:14
Wohnort: Würzburg

Re: Umsatzabruf Volkswagenbank funktioniert nicht mehr

Beitrag von Hibiscus-Scripter » Do 30. Apr 2020, 20:20

ah ok Danke :thumbup:
Das muss ich mal überarbeiten :think:

Dann lag es an der IBAN (nur die Prüfungen und Meldungen passen nicht).

Gruß :wave:
... wer lesen kann ist wie immer im klaren Vorteil ...

:!: Vor dem Posten: Bitte die Posting-Regeln für neue Beiträge lesen und bitte auch immer alle 4. Punkte zur Fehlermeldung beachten (Der Post wird ansonsten gelöscht)

:idea: Hilfe und Informationen zu den Test- und Nightly-Builds und deren Installation findet Ihr z. B. im Tipps und Tricks-Forum (Weitere hilfreiche Artikel findet man in der FAQ auf der Projekt-Website)

Wer ein Dankeschön für die Arbeit und Unkosten senden möchte, kann gerne auch :arrow: Spenden

jottka
Beiträge: 12
Registriert: Mi 14. Mär 2018, 11:23

Re: Umsatzabruf Volkswagenbank funktioniert nicht mehr

Beitrag von jottka » Fr 1. Mai 2020, 11:41

Hallo Hibiscus-Scripter,
heute kam der neue Chromium 81 über die Ubuntu-Aktualisierung und danach habe ich sofort noch einmal eine Konten-Aktualisierung gemacht. Es hat geklappt, allerdings kam eine Warnung: VWBank-Logout war fehlerhaft; Bitte dem Entwickler im Forum melden!

Code: Alles auswählen

[01.05.2020 09:48:16] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[01.05.2020 09:48:16]  
[01.05.2020 09:48:16] System-Info: OS[Linux (ver. 4.15.0-99-generic) amd64]  Platform[Jameica 2.8.6 | Build: 455 vom 20191101]  Plugin[hibiscus 2.8.23 | Build: 387 vom 20200114]
[01.05.2020 09:48:16] Installierte und aktive Plugin-Versionen: [Finance.Websync ver. 0.9.11-nightly | Build: 596 vom 20200427] [Hibiscus Mashup ver. 0.9.11-nightly | Build: 385 vom 20200426]
[01.05.2020 09:48:16] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[01.05.2020 09:48:16] OK: Java-Version 1.8.0_241 von 'Oracle Corporation' installiert, aktiv und verwendet Zeichensatz 'UTF-8' (Home: /opt/jameica/javaruntime)
[01.05.2020 09:48:16] Überprüfe Selenium-Version ...
[01.05.2020 09:48:16] OK: Selenium-Version 3.141.59 installiert und aktiv
[01.05.2020 09:48:16] Überprüfe ChromeDriver-Version ...
[01.05.2020 09:48:17] OK: ChromeDriver-Version 81.0.4044.69 installiert und aktiv
[01.05.2020 09:48:17]  
[01.05.2020 09:48:17] Synchronisiere Konto 'Volkswagenbank - Giro, IBAN DE84**..****** [Volkswagen Bank]' ...
[01.05.2020 09:48:17] Selenium WebDriver über ChromeDriver wird gestartet ...
[01.05.2020 09:48:20] Überprüfe Chrome-Version ...
[01.05.2020 09:48:20] OK. Browser ist: chrome ver. 81
[01.05.2020 09:48:20] Chrome gefunden. Alternativer Chromium wird daher nun wieder entfernt ...
[01.05.2020 09:48:22] Web-Login mit Selenium-WebDriver-Engine mit Anmeldekennung *********** auf https://banking.vwfs.de/PBODE-FE-UI/#/login ...
[01.05.2020 09:49:24] VWBank-Login war erfolgreich
[01.05.2020 09:49:24] Rufe Umsatzübersicht auf und starte Abruf des Kontoauszuges ...
[01.05.2020 09:49:24] Suche Umsätze im Zeitraum vom 16.04.2020 bis 01.05.2020 und lese diese aus ...
[01.05.2020 09:49:54] Web-Logout der aktuellen Online-Sitzung ...
[01.05.2020 09:49:58] Warnung: VWBank-Logout war fehlerhaft; Bitte dem Entwickler im Forum melden!
[01.05.2020 09:49:59] Kontoauszug erfolgreich. Importiere Daten ...
[01.05.2020 09:49:59] Ergebnis des Sync: Keine neuen Umsätze vorhanden
[01.05.2020 09:49:59] Saldo aktualisiert von Konto: Volkswagenbank - Giro
[01.05.2020 09:49:59] Das Konto 'Volkswagenbank - Giro, IBAN DE84**..****** [Volkswagen Bank]' wurde erfolgreich synchronisiert
[01.05.2020 09:49:59]  
[01.05.2020 09:49:59] Synchronisiere Konto 'Volkswagenbank - Orderkonto, IBAN DE57**..****** [Volkswagen Bank]' ...
[01.05.2020 09:50:00] Selenium WebDriver über ChromeDriver wird gestartet ...
[01.05.2020 09:50:01] Überprüfe Chrome-Version ...
[01.05.2020 09:50:01] OK. Browser ist: chrome ver. 81
[01.05.2020 09:50:02] Web-Login mit Selenium-WebDriver-Engine mit Anmeldekennung *********** auf https://banking.vwfs.de/PBODE-FE-UI/#/login ...
[01.05.2020 09:50:37] VWBank-Login war erfolgreich
[01.05.2020 09:50:37] Rufe Umsatzübersicht auf und starte Abruf des Kontoauszuges ...
[01.05.2020 09:50:37] Suche Umsätze im Zeitraum vom 25.03.2020 bis 01.05.2020 und lese diese aus ...
[01.05.2020 09:51:05] Web-Logout der aktuellen Online-Sitzung ...
[01.05.2020 09:51:09] Warnung: VWBank-Logout war fehlerhaft; Bitte dem Entwickler im Forum melden!
[01.05.2020 09:51:09] Kontoauszug erfolgreich. Importiere Daten ...
[01.05.2020 09:51:09] Ergebnis des Sync: Es wurde ein neuer Umsatz übernommen
[01.05.2020 09:51:09] Saldo aktualisiert von Konto: Volkswagenbank - Orderkonto
[01.05.2020 09:51:09] Das Konto 'Volkswagenbank - Orderkonto, IBAN DE57**..****** [Volkswagen Bank]' wurde erfolgreich synchronisiert
[01.05.2020 09:51:09]  
[01.05.2020 09:51:09] Synchronisiere Konto 'Volkswagenbank - Visa-Card, IBAN DE15**..****** [Volkswagen Bank]' ...
[01.05.2020 09:51:09] Selenium WebDriver über ChromeDriver wird gestartet ...
[01.05.2020 09:51:10] Überprüfe Chrome-Version ...
[01.05.2020 09:51:10] OK. Browser ist: chrome ver. 81
[01.05.2020 09:51:11] Web-Login mit Selenium-WebDriver-Engine mit Anmeldekennung *********** auf https://banking.vwfs.de/PBODE-FE-UI/#/login ...
[01.05.2020 09:51:39] VWBank-Login war erfolgreich
[01.05.2020 09:51:39] Rufe Umsatzübersicht auf und starte Abruf des Kontoauszuges ...
[01.05.2020 09:51:39] Suche Umsätze im Zeitraum vom 16.04.2020 bis 01.05.2020 und lese diese aus ...
[01.05.2020 09:52:08] Web-Logout der aktuellen Online-Sitzung ...
[01.05.2020 09:52:12] Warnung: VWBank-Logout war fehlerhaft; Bitte dem Entwickler im Forum melden!
[01.05.2020 09:52:12] Kontoauszug erfolgreich. Importiere Daten ...
[01.05.2020 09:52:12] Ergebnis des Sync: Keine neuen Umsätze vorhanden
[01.05.2020 09:52:13] Saldo aktualisiert von Konto: Volkswagenbank - Visa-Card
[01.05.2020 09:52:13] Das Konto 'Volkswagenbank - Visa-Card, IBAN DE15**..****** [Volkswagen Bank]' wurde erfolgreich synchronisiert
[01.05.2020 09:52:13] Synchronisierung via non-HBCI (Hibiscus Mashup) erfolgreich beendet
Dann lag es an der IBAN (nur die Prüfungen und Meldungen passen nicht).
Das kann es doch gestern eigentlich nicht gewesen sein, denn die IBAN hat nur bei einem Konto in den Zugangsdaten gefehlt, bei den anderen nicht. Es lies sich aber doch kein Konto synchronisieren! Ich hatte ja gestern bei den Zugangsdaten unter Verfahren bei allen Konten 'PIN/TAN Web (non-HBCI)' eingestellt und gespeichert, diese Enstellung ist heute wieder weg und es steht 'Bitte wählen...' dort.
Übrigens hatte ich die Probleme mit der Synchronisierung seit dem letzten Mashup-Update Anfang April und an den Zugangsdaten habe ich seit Jahren nichts geändert. Ich nutze Hibiscus bestimmt schon seit 15 Jahren sehr erfolgreich, erst mit HBCI und nach einem Bankwechsel auch bestimmt schon seit sieben oder acht Jahren mit Deinen Scripten.

Gruß

Zurück zu „Hibiscus Mashup über Finance.Websync - (Beta 0.x = neue Release 3 der alten Scripte)“