SWTError: no underlying browser available: Please ensure that WebKit with its GTK 3.x/4.x bindings is installed

Alle Fragen die nicht direkt unter Support zu einem der Scripte gezählt werden können
LoganMCV
Beiträge: 3
Registriert: Di 7. Nov 2023, 13:00

SWTError: no underlying browser available: Please ensure that WebKit with its GTK 3.x/4.x bindings is installed

Beitrag von LoganMCV » Di 7. Nov 2023, 13:10

@All
Hallo ich bin Micha und neu im Linux Bereich.
Versuche auf Linux , Kubuntu (gefällt mir persöhnlich am besten) umzusteigen.
Habe fast alles installiert bekommen was ich so brauche.
Leider bekomme ich jetzt aber bei hibiscus immer Fehler bei meiner Santander Bank ausgegeben.

Code: Alles auswählen

[07.11.2023 09:55:09] Synchronisierung via non-HBCI (Hibiscus Mashup) läuft
[07.11.2023 09:55:09]  
[07.11.2023 09:55:09] System-Info: OS[Linux (ver. 6.5.0-10-generic) amd64]  Platform[Jameica 2.10.4 | Build: 487 vom 20230414]  Plugin[hibiscus 2.10.15 | Build: 379 vom 20231103]
[07.11.2023 09:55:09] Installierte und aktive Plugin-Versionen: [Finance.Websync ver. 0.9.71 | Build: 1050 vom 20231105] [Hibiscus Mashup ver. 0.9.39 | Build: 585 vom 20231105]
[07.11.2023 09:55:09] Überprüfe Jameica-Version ...
[07.11.2023 09:55:09] OK: Jameica-Version 2.10.4 installiert und aktiv
[07.11.2023 09:55:09] Überprüfe Java-Version und den verwendeten Zeichensatz ...
[07.11.2023 09:55:09] OK: Java-Version 17.0.8 von 'Azul Systems, Inc.' installiert, aktiv und verwendet Zeichensatz 'UTF-8' (Home: /opt/jameica/javaruntime)
[07.11.2023 09:55:09] Überprüfe BrowserUpProxy-Version ...
[07.11.2023 09:55:09] OK: BrowserUpProxy-Version 2.2.14 installiert und aktiv
[07.11.2023 09:55:09] Überprüfe Selenium-Version ...
[07.11.2023 09:55:09] OK: Selenium-Version 4.14.1 installiert und aktiv
[07.11.2023 09:55:09] Überprüfe ChromeDriver-Version ...
[07.11.2023 09:55:09] OK: ChromeDriver-Version 119.0.6045.105 installiert und aktiv
[07.11.2023 09:55:09] Überprüfe PDFBox-Version ...
[07.11.2023 09:55:09] OK: PDFBox-Version 2.0.30 installiert und aktiv
[07.11.2023 09:55:09]  
[07.11.2023 09:55:09] Synchronisiere Konto 'Girokonto, IBAN DE1431..942956 [Santander Consumer Bank]' ...
[07.11.2023 09:55:10] ChromeDriver Applikation-Proxy Einstellungen auf BrowserUp Proxy einstellen ...
[07.11.2023 09:55:10] ChromeDriver Proxy-Einstellungen setzen ...
[07.11.2023 09:55:10] OK: Es wird der HTTPS-Proxy von der Applikation benutzt
[07.11.2023 09:55:10] Selenium WebDriver über ChromeDriver wird gestartet ...
[07.11.2023 09:55:11] Überprüfe Chrome-Version ...
[07.11.2023 09:55:11] OK. Browser ist: chrome ver. 119
[07.11.2023 09:55:11] Chrome gefunden. Alternativer Chromium wird daher nun wieder entfernt ...
[07.11.2023 09:55:15] Web-Login mit Selenium-WebDriver-Engine mit Anmeldekennung 9722******* auf https://meine.santander.de/olb ...
[07.11.2023 09:55:16] Fehler: Exception bei Auth.Login! Fehlernachricht: Santander-Login fehlgeschlagen! org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.RuntimeException: org.eclipse.swt.SWTError: No more handles because there is no underlying browser available.
Please ensure that WebKit with its GTK 3.x/4.x bindings is installed.)
	at org.eclipse.swt.SWT.error(SWT.java:4918)
	at org.eclipse.swt.SWT.error(SWT.java:4833)
	at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:209)
	at org.eclipse.swt.widgets.Display.syncExec(Display.java:5960)
	at de.derrichter.hibiscus.mashup.gui.dialogs.AbstractDialog.open(AbstractDialog.java:550)
	at de.derrichter.hibiscus.mashup.crossover.callback.WebDialogs.askPIN(WebDialogs.java:373)
	at de.derrichter.hibiscus.mashup.crossover.interact.Auth.getPasswort(Auth.java:112)
	at de.derrichter.hibiscus.mashup.crossover.interact.Auth.seleniumLogin(Auth.java:342)
	at de.derrichter.hibiscus.mashup.crossover.websync.institute.santanderconsumerbank.Collector.run(Collector.java:287)
	at de.derrichter.hibiscus.mashup.crossover.websync.WebSynchronizeJobKontoauszug.execute(WebSynchronizeJobKontoauszug.java:84)
	at de.derrichter.hibiscus.mashup.crossover.websync.WebSynchronizeBackend$WebSyncJobGroup.sync(WebSynchronizeBackend.java:890)
	at de.willuhn.jameica.hbci.synchronize.AbstractSynchronizeBackend$Worker.run(AbstractSynchronizeBackend.java:399)
	at de.willuhn.jameica.gui.GUI$7.run(GUI.java:1107)
Caused by: java.lang.RuntimeException: org.eclipse.swt.SWTError: No more handles because there is no underlying browser available.
Please ensure that WebKit with its GTK 3.x/4.x bindings is installed.
	at de.derrichter.hibiscus.mashup.gui.dialogs.AbstractDialog$4.run(AbstractDialog.java:564)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:40)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:132)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:5040)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4520)
	at de.willuhn.jameica.gui.GUI.loop(GUI.java:938)
	at de.willuhn.jameica.gui.GUI.init(GUI.java:335)
	at de.willuhn.jameica.system.Application.init(Application.java:145)
	at de.willuhn.jameica.system.Application.newInstance(Application.java:87)
	at de.willuhn.jameica.Main.main(Main.java:78)
Caused by: org.eclipse.swt.SWTError: No more handles because there is no underlying browser available.
Please ensure that WebKit with its GTK 3.x/4.x bindings is installed.
	at org.eclipse.swt.SWT.error(SWT.java:4944)
	at org.eclipse.swt.browser.Browser.<init>(Browser.java:119)
	at de.derrichter.hibiscus.mashup.gui.dialogs.security.PasswordDialog.paint(PasswordDialog.java:326)
	at de.derrichter.hibiscus.mashup.gui.dialogs.security.PinDialog.paint(PinDialog.java:129)
	at de.derrichter.hibiscus.mashup.gui.dialogs.AbstractDialog$4.run(AbstractDialog.java:560)
	... 9 more


Tipp: Sollten Sie mit dieser Fehlermeldung nichts anfangen können, bitte helfen Sie uns:
Installieren Sie alle Updates und verwenden für das Jameica-Upgrade das Rundum-Sorglos-Paket (https://hibiscus-mashup.derrichter.de/index.php/download)
Suchen Sie diese im Support-Forum über Menü Mashup->Online-Supportforum (https://scripting-forum.derrichter.de/viewforum.php?f=34)
Ist keine Lösung vorhanden, kopieren Sie am besten gleich, mit einem Klick auf den 'Text kopieren'-Button, hier rechts in der Fensterleiste,
den gesamten Inhalt dieses Status-Log, erstellen ein 'Neues Thema' im Forum und fügen dies in einem Code-Block ein. (Erst den </>-Button, dann Einfügen)
Damit kann Ihnen geholfen werden und Sie weisen uns darauf hin. Vielen Dank
Leider kann ich damit nichts anfangen könnte mir jemand sagen ,schreiben was ich tun kann.
Danke schon mal im vorraus
Gruß Micha

hbci
VIP
VIP
Beiträge: 818
Registriert: Sa 7. Mär 2020, 15:01
Has thanked: 25 times
Been thanked: 37 times

Re: Santander Fehler

Beitrag von hbci » Di 7. Nov 2023, 14:52

Hast du folgendes beachtet?

Code: Alles auswählen

Please ensure that WebKit with its GTK 3.x/4.x bindings is installed.
Schau mal, ob hier was Hilfreiches zu deinem Problem steht.

LoganMCV
Beiträge: 3
Registriert: Di 7. Nov 2023, 13:00

Re: Santander Fehler

Beitrag von LoganMCV » Di 7. Nov 2023, 15:20

@ All

Kann mir jemand schreiben wie ich das installieren kann.

So ich habe was gefunden wo mit ich was anfangen kann und konnte.
Da ich Kubuntu 23.10 installiert habe
Auf dieser Seite
https://debian.pkgs.org/12/debian-main- ... 4.deb.html

Code: Alles auswählen

1. Update the package index:
sudo apt-get update
2. Install libwebkit2gtk-4.0-37 deb package:
sudo apt-get install libwebkit2gtk-4.0-37
Danke
Gruß Micha

hbci
VIP
VIP
Beiträge: 818
Registriert: Sa 7. Mär 2020, 15:01
Has thanked: 25 times
Been thanked: 37 times

Re: Santander Fehler

Beitrag von hbci » Mi 8. Nov 2023, 18:52

Und läuft der Abruf nun?

LoganMCV
Beiträge: 3
Registriert: Di 7. Nov 2023, 13:00

Re: Santander Fehler

Beitrag von LoganMCV » Mi 8. Nov 2023, 22:20

@All
Habe ich vergessen zuschreiben, ja es läuft wieder ohne Probleme.
Gruß Micha

Zurück zu „Für Einsteiger“